• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

5400 Help please

FRAZER

Regular Member
Messages
92
Likes
0
#1
I've just bought a Humax 5400, supposedly with the latest patch installed (I asked them to check that it was 2.4 or above), but I can't get any of the goldwafer files for patched Humaxes to work- the "smartcard is accepted" message comes up on insertion (which it doesn't with an ordinary Viaccess card), but every channel brings just the "service is not running or scrambled message".

I tried some straight Irdeto files, and got most of Dutch Canal+ and some of Nova working, and on other occasions these threw up the "the card has no rights for this service" message, but Stream, as well as Premier and ORF, always brought up the normal "service is not running..." message.

Does anyone have any ideas as to what I should be trying? Is there any way I can check that my machine actually is patched (but shouldn't Stream work without the patch?)- the conditional access menu shows Softcell 2.07 PH, and Euro chip version NEC V2.1.
Can I patch it myself the same way you update software for Humax machines normally (ie via the RS232 port)? But I guess if I did this, I would not be able to take it back to the shop- are there any risks involved?

Sorry for quite so many questions, but, as you've heard before no doubt, I've just spent all this money......

Thank you,

Frazer
 

FRAZER

Regular Member
Messages
92
Likes
0
#2
Just to update my own message, I just updated an old Alfredo V17 file and got Premiere working- does this mean I'm definately patched? If so, what's wrong with the seca/viaccess in irdeto files- I've made sure some of those are updated as well, but had no luck. Likewise even the V17 file failed on Stream even with updated keys.

Help still needed if possible!

Frazer
 

2old4this

Honorary Admin
Messages
1,658
Likes
0
My Location
Cloud Cuckoo Land
#3
If you can get any betacrypt-encrypted channels at ball (Premiere-World being one such example) then yes, your Humax 5400 is patched - since in its original form the embedded Irdeto CAM is not an AllCAM. But there are different forms of patch. The AllCAM patch first released only allows Irdeto&Betacrypt through.

And yes, you can upgrade the software yourself. This is a non-invasive procedure (ie you don't need to tinker with then insides or anything). And as for the shop not accepting it back if you do, I hardly think they would have a leg to stand on. They are legally-speaking skating on very thin ice by patching the embedded Irdeto in the first place. Mindport does not allow reverse-engineering of its encryption system. Why do you think Humax have now been pressured into modifying the 5400 to be non-patchable...? In fact I would expect that Humax themselves would now take a strong line (including terminating dealerships) against dealers that modify their product...

For the multi-encryption facility there are various revisions of the patched firmware available. The latest was v3.1 so you should apply that and see what (if any) problems you are left with.

2old
 

FRAZER

Regular Member
Messages
92
Likes
0
#4
Thanks again for the reply.

As you may have read in my other thread ("Big trouble"), I decided to try patching the receiver again myself, had a bit of a nightmare when it stopped working completely, and then managed to sort it out so that the new patch is working fine with the seca/viaccess in irdeto files (though, ironically, I'm having trouble finding reliable files for the irdeto channels at the moment).

I guess the patch the machine came with was nothing like the latest one, but everything worked out well in the end.

Frazer