another 5620 boot problem,help please

kitoog

Regular Member
Messages
76
Likes
0
My Satellite Setup
dreambox 7000s w/160 Gb hdd
superjack dg120 diseqc motor
lidl 80cm dish and lnb
My Location
ireland
#1
trying to repair mates 5620 which will not boot,just has 5600 boot scrolling across screen.with hyperterminal i get following output,then hangs

Dreambox DM5620
loaded at: 00500000 005FE16C
relocated to: 00400000 004FE16C
board data at: 004FC124 004FC16C
relocated to: 00405194 004051DC
zimage at: 004058D1 004FB548
avail ram: 004FF000 02000000

Linux/PPC load: console=null root=/dev/mtdblock5 rootfstype=squashfs ro
Uncompressing Linux...done.
Now booting the kernel

can get dreamup universal to detect 5620 but hangs on initiating flash upload.will not upload the present flash.is there anything else i can try before i have to resort to a jtag.the warranty is up at this stage i would think.
cheers
kitoog
 

T_G

The Consumate Dreamer
Staff member
Messages
6,638
Likes
211
My Satellite Setup
1 GigaBlue Quad plus, 1 Dreambox 5620, MOTECK SG2100A DISEqC Motor, 120 cm noname offset dish, Humax 95 cm offset dish and a few UK digiboxes.
My Location
Somewhere where the Sauer is Kraut and the Wurst is Brat
#2
kitoog said:
trying to repair mates 5620 which will not boot,just has 5600 boot scrolling across screen.with hyperterminal i get following output,then hangs

Dreambox DM5620
loaded at: 00500000 005FE16C
relocated to: 00400000 004FE16C
board data at: 004FC124 004FC16C
relocated to: 00405194 004051DC
zimage at: 004058D1 004FB548
avail ram: 004FF000 02000000

Linux/PPC load: console=null root=/dev/mtdblock5 rootfstype=squashfs ro
Uncompressing Linux...done.
Now booting the kernel

can get dreamup universal to detect 5620 but hangs on initiating flash upload.will not upload the present flash.is there anything else i can try before i have to resort to a jtag.the warranty is up at this stage i would think.
cheers
kitoog
So you tried the official dreamUp 5620 V2.14b 20030416 and tried to load up an official Dreambox image and then it hangs??
 

kitoog

Regular Member
Messages
76
Likes
0
My Satellite Setup
dreambox 7000s w/160 Gb hdd
superjack dg120 diseqc motor
lidl 80cm dish and lnb
My Location
ireland
#3
ye tried that official and other 5620 dreamup's,but will not connect.with universal dreamup it detects 5620 being present,but thats it,will not connect just like the others.tried hyperterminal many times also ,but always get same output,as stated above.
 

T_G

The Consumate Dreamer
Staff member
Messages
6,638
Likes
211
My Satellite Setup
1 GigaBlue Quad plus, 1 Dreambox 5620, MOTECK SG2100A DISEqC Motor, 120 cm noname offset dish, Humax 95 cm offset dish and a few UK digiboxes.
My Location
Somewhere where the Sauer is Kraut and the Wurst is Brat
#4
kitoog said:
ye tried that official and other 5620 dreamup's,but will not connect.with universal dreamup it detects 5620 being present,but thats it,will not connect just like the others.tried hyperterminal many times also ,but always get same output,as stated above.
Hmmm can't help you further...I heard that there are "Erase Images" available for some boxes, that can be used for bad cases of boot problems, but I cannot say where to get them, nor do I have any experience with them. Don't even know if they work or not.

I suppose you probably checked all this, but make sure you got the correct null modem cable and disabled all network options, removed all connectors from box etc. Also, maybe try loading some of the older original Images such as the 1.06.

Another one to look at: In the database at the IHAD site there is a Dreamup DreamUP-1.1.0.3-BETA version where it says: Version 1.1.0.3

- fix: timing beim loader-upload geändert, einige Boxen blieben dort "hängen"
i.e it fixes the problem where boxes hang. They got a whole lot of dream up progs there, I would start from the top one DreamUp v 1.2.1.5 and work my way down.

In any case, keep trying because I haven't heard yet of a 5620 that would not load up with a null modem and the official software in the end.
 

kitoog

Regular Member
Messages
76
Likes
0
My Satellite Setup
dreambox 7000s w/160 Gb hdd
superjack dg120 diseqc motor
lidl 80cm dish and lnb
My Location
ireland
#5
got it working thankfully. using my laptop with usb to serial cable,as it has no serial port ,i connected with hyperterminal showing boot config etc.i followed the tips below by skyshark @ sat-industry forum.

Disconnect the Dreambox from the AC outlet for 2 minutes.
Connect the RS232 cable as if you wanted to flash with DreamUp.

On your PC start Hyperterminal with following parameters:
- Name = Dreambox
- COM port 1 or 2 (your physical COM port on which nullmodem cable is connected)
- Bits per second = 115200
- Data bits = 8
- Parity = None
- Stop bits = 1
- Flow control = Xon / Xoff

Now you should see a white window with a blinking cursor.

Switch Dreambox ON and pay attention immeditalely to the PC monitor. You have to be quick now. When whatever appears on the screen, hit Enter twice quickly: a menu has to be appear on the screen.
The menu shows if the flash memory is enabled for booting. If not, set it enabled. Set all media enabled for booting!
After that continue the boot process via Hyperterminal.

At this moment Dreambox may hang; don't worry yet. If so, disconnect it form the AC outlet again.
Close Hyperterminal.
Start DreamUp.
Switch the Dreambox on. The DreamUp must show "Waiting for acknowledge", then "Connection established".
1. It everything was happened like above, it's time to have a glass of beer. The rest steps needed you will find here .
2. If the Hyperterminal doesn't shows anything or later the DreamUp doesn't shows "Connection established" it's a pity: probably you will need to JTAG your box.


this time i booted the box by doing a 3 button boot,leaving power switch on and releasing three buttons to boot box.before i booted the box by turning on switch at back of the box.boot settings in configuration with hyperterminal were fine,so i toggled boot to disabled,back to enabled, saved and exited as below.when i tried dreamup this time, i just released three front buttons on the 5620 to boot and connected first time.if i booted box this way from start with dreamup i possibly would have had no problems doing the flash erase in the first place:-doh!.box is back to normal now with gemini installed,but i still cannot get a signal through diseqc motor with it.tried other motor a few months back,no luck with any image.can only get signal with direct connection to lnb.any idea of how you would fix that or is it possibly a hardware error.
cheers for your input
kitoog
 

T_G

The Consumate Dreamer
Staff member
Messages
6,638
Likes
211
My Satellite Setup
1 GigaBlue Quad plus, 1 Dreambox 5620, MOTECK SG2100A DISEqC Motor, 120 cm noname offset dish, Humax 95 cm offset dish and a few UK digiboxes.
My Location
Somewhere where the Sauer is Kraut and the Wurst is Brat
#6
kitoog said:
got it working thankfully. using my laptop with usb to serial cable,as it has no serial port ,i connected with hyperterminal showing boot config etc.i followed the tips below by skyshark @ sat-industry forum.
Hi Kitoog

First of all, good to hear that you managed to get it going.
I think this is a very important issue that needs to be entered into the idiot guide, many users have this or that question regarding the boot problem.

So, do you feel like entering it into the guide? All you need to do is make sure it is easy to understand, add whatever you think might be important, and don't forget to mention where you got some of the texts. If yes, simply go to the idiot guide and add a post. I will later add the links and the index entry.

How about it, wanna join the Round Table? :)

TG
 

D4ftpunk

Regular Member
Messages
358
Likes
0
My Satellite Setup
Dreambox 7020
Dreambox DM500
Sky Thomsom Digibox
StrongSat FTA Reciever
80cm Dish + 45cm Dish via Disecq A/B.
My Location
England
#7
I know you have fixed it now, but im curious could you get telnet access to it ?
 

kitoog

Regular Member
Messages
76
Likes
0
My Satellite Setup
dreambox 7000s w/160 Gb hdd
superjack dg120 diseqc motor
lidl 80cm dish and lnb
My Location
ireland
#8
@ T_G ,will add it if you would like,but i am not sure if i did anything new myself.i just followed skyshark's guide,maybe better just add his guide if that is possible.

@ D4ftpunk , i did not have an ip as i think the dhcp on the box was using wrong gateway.even now i have to set the ip manually ,even though i have dhcp enabled on my network.if i enable dhcp on the box it gets totally wrong gateway,dns server etc.
 

T_G

The Consumate Dreamer
Staff member
Messages
6,638
Likes
211
My Satellite Setup
1 GigaBlue Quad plus, 1 Dreambox 5620, MOTECK SG2100A DISEqC Motor, 120 cm noname offset dish, Humax 95 cm offset dish and a few UK digiboxes.
My Location
Somewhere where the Sauer is Kraut and the Wurst is Brat
#9
kitoog said:
@ T_G ,will add it if you would like,but i am not sure if i did anything new myself.i just followed skyshark's guide,maybe better just add his guide if that is possible.
I would prefer if you had a go at it, as you went through the whole thing. my box is working fine at the moment and I don't feel like upsetting the missus to try out all the things.
Also, add any of your own experiences and ideas to it (Many sections of the Idiot Guide have been written after I went through all sorts of forums and guides and took out all the bits that are important, but mostly I found that many guides are not user friendly, and then you get all frustrated when it does not work.)
There isn't a guide which is perfect, but I think you will find that our guide is written so that anybody can get it. I appreciate that you followed instructions from somewhere, and it is important to mention where it comes from, but you tried various things a few times without success and all this experinece needs to go in. What to do, what not to do, a few screenshots of the settings, you know the deal :)

Also, what is not written (or not very clear) in the instructions from the other forum is all about the telnetting, the nullmodem cable etc etc.

I reckon you should start and then we will all add to it whenever we find new stuff - so it will be a dogs bollocks section of the guide about the booting problems.

There is no hurry, and you don't need to do it if you really don't want to, but it would be nice for other users to have it just in case...

And it would make me really happy as well :p
 
Messages
3
Likes
0
My Satellite Setup
DREAMBOX 500C
My Location
Brasil
#10
kitoog said:
got it working thankfully. using my laptop with usb to serial cable,as it has no serial port ,i connected with hyperterminal showing boot config etc.i followed the tips below by skyshark @ sat-industry forum.

Disconnect the Dreambox from the AC outlet for 2 minutes.
Connect the RS232 cable as if you wanted to flash with DreamUp.

On your PC start Hyperterminal with following parameters:
- Name = Dreambox
- COM port 1 or 2 (your physical COM port on which nullmodem cable is connected)
- Bits per second = 115200
- Data bits = 8
- Parity = None
- Stop bits = 1
- Flow control = Xon / Xoff

Now you should see a white window with a blinking cursor.

Switch Dreambox ON and pay attention immeditalely to the PC monitor. You have to be quick now. When whatever appears on the screen, hit Enter twice quickly: a menu has to be appear on the screen.
The menu shows if the flash memory is enabled for booting. If not, set it enabled. Set all media enabled for booting!
After that continue the boot process via Hyperterminal.

At this moment Dreambox may hang; don't worry yet. If so, disconnect it form the AC outlet again.
Close Hyperterminal.
Start DreamUp.
Switch the Dreambox on. The DreamUp must show "Waiting for acknowledge", then "Connection established".
1. It everything was happened like above, it's time to have a glass of beer. The rest steps needed you will find here - _http://sat-industry.net/forums/showthread.php?t=20775.
2. If the Hyperterminal doesn't shows anything or later the DreamUp doesn't shows "Connection established" it's a pity: probably you will need to JTAG your box.


this time i booted the box by doing a 3 button boot,leaving power switch on and releasing three buttons to boot box.before i booted the box by turning on switch at back of the box.boot settings in configuration with hyperterminal were fine,so i toggled boot to disabled,back to enabled, saved and exited as below.when i tried dreamup this time, i just released three front buttons on the 5620 to boot and connected first time.if i booted box this way from start with dreamup i possibly would have had no problems doing the flash erase in the first place:-doh!.box is back to normal now with gemini installed,but i still cannot get a signal through diseqc motor with it.tried other motor a few months back,no luck with any image.can only get signal with direct connection to lnb.any idea of how you would fix that or is it possibly a hardware error.
cheers for your input
kitoog
Hi, I have exactly the same problem but my box is DM500. Do you think this trick with enter during Hyperterminal startup works also for this box? Thanks a lot!
 
Top