• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Digisat Pro meter

Milkybarkid

Regular Member
Messages
245
Likes
1
#1
I've had a Digisat Pro meter for a few years and it's been fine. I use it as a meter and as a diseqc switch as it has two inputs.I have it connected to my Technomate receiver. Yesterday I unplugged one of the dishes and plugged in a new one and the meter, Tv and sat receiver all switched off. I tried to switch the receiver back on but nothing happened. I waited a few minutes and managed to switch back on the receiver, Tv and plugged in a dish into the meter and all was working. Only thing is when I plug the meter in I ususally get a reading on LNB input one and two of 1.5 and then when I plug a dish in it goes to 25,30 or whatever.
Now when I plug the meter into the receiver there is a static reading of 32.6 on both LNB inputs even though nothing is plugged into the LNB inputs and when I plug in a dish it stays at 32.6. And now only LNB2 input is working.

Have I shorted something yesterday when I plugged in a dish into the meter ?
Is it now kaput ?

Thanks.
 

rolfw

Believe it when I see it Admin.
Staff member
Messages
37,594
Likes
1,252
My Satellite Setup
See signature
My Location
Berkshire
#2
Sounds like you may have done it in, possibly a short or surge.

I'm assuming that both LNBs work when connected directly?
 

rolfw

Believe it when I see it Admin.
Staff member
Messages
37,594
Likes
1,252
My Satellite Setup
See signature
My Location
Berkshire
#4
Send it to Emitor, they'll probably repair it.:)