Edision Primo IP S2 Latest Firmware

S

Stevenvc19

Member
Messages
44
My Satellite Setup
Edision Primo S2:
5W
9E
13E
19.2E
28.2E
My Location
Willebroek Belgium
HD Subtitles were fixed months ago.
Only the first line of subtitles is showed. So when you watch a movie with short sentences, no problem... but when there should be more than one line of subtitles showing, it only shows the first line. Can you confirm the same issue?
Only on the German channels the subtitles are working alright. Check ITV HD, Channel 4 or TF1

And teletext (subtitles) won’t record

Also the subtitles won’t show during a recording or they won’t show at all until you reboot the box... I can go on for hours talking about subtitles issues :)
 
Analoguesat

Analoguesat

Administrator
Staff member
Messages
46,744
Location
Scottish Borders
My Satellite Setup
TM 5402HD
Skybox F3
Sky+ UK.
My Location
Scottish Borders
Sounds like Edision are the new Fortec. (Fortec were notorious for dropping support for a receiver once it had been on the market for a year to 18 months)
 
Lazarus

Lazarus

Tout Rond Bon Oeuf
Staff member
Messages
25,411
My Satellite Setup
80cm Motorised.
Several small Dishes.
Much else.
My Location
North York Moors
Only the first line of subtitles is showed. So when you watch a movie with short sentences, no problem... but when there should be more than one line of subtitles showing, it only shows the first line. Can you confirm the same issue?
Only on the German channels the subtitles are working alright. Check ITV HD, Channel 4 or TF1

And teletext (subtitles) won’t record

Also the subtitles won’t show during a recording or they won’t show at all until you reboot the box... I can go on for hours talking about subtitles issues :)

I'll have a look tomorrow and report back.

Been out this evening and now SWMBO has possession of the Telecommander!
 
scopus

scopus

Specialist Contributor
Messages
2,099
My Satellite Setup
Primesat/Famaval 1.8 PF C/ku/Ka, Octagon SX8HD1, SX88, Openbox S3 Mini HD-V8S Freesat V7 HD-V8 Finder, Amiko A4K Combo, Satlook Colour HD Spectrum, Sansui A909 Amp and BOSE Acoustimass speakers for the audio.
My Location
Staffs UK
Sounds like Edision are the new Fortec. (Fortec were notorious for dropping support for a receiver once it had been on the market for a year to 18 months)
Yes, totally agree. I had a Fortec Star Beta receiver, only had one update, then support dropped, plus that other pile of junk the Passion, that receiver was more like a Passion killer!
 
Lazarus

Lazarus

Tout Rond Bon Oeuf
Staff member
Messages
25,411
My Satellite Setup
80cm Motorised.
Several small Dishes.
Much else.
My Location
North York Moors
Only the first line of subtitles is showed. So when you watch a movie with short sentences, no problem... but when there should be more than one line of subtitles showing, it only shows the first line. Can you confirm the same issue?
Only on the German channels the subtitles are working alright. Check ITV HD, Channel 4 or TF1

And teletext (subtitles) won’t record

Also the subtitles won’t show during a recording or they won’t show at all until you reboot the box... I can go on for hours talking about subtitles issues :)
You're right

Using Firmware v1.04.62


ITV HD One line only. Nicely positioned lower left quadrant.
C4HD One line only, appearing at various places depending upon the dialogue. Very distracting.
TF1 HD One line only. Positioned lower right quadrant.
 
S

Stevenvc19

Member
Messages
44
My Satellite Setup
Edision Primo S2:
5W
9E
13E
19.2E
28.2E
My Location
Willebroek Belgium
You're right

Using Firmware v1.04.62


ITV HD One line only. Nicely positioned lower left quadrant.
C4HD One line only, appearing at various places depending upon the dialogue. Very distracting.
TF1 HD One line only. Positioned lower right quadrant.
So basicaly the subtitles are worthless for those channels... :(
 
scopus

scopus

Specialist Contributor
Messages
2,099
My Satellite Setup
Primesat/Famaval 1.8 PF C/ku/Ka, Octagon SX8HD1, SX88, Openbox S3 Mini HD-V8S Freesat V7 HD-V8 Finder, Amiko A4K Combo, Satlook Colour HD Spectrum, Sansui A909 Amp and BOSE Acoustimass speakers for the audio.
My Location
Staffs UK
So basicaly the subtitles are worthless for those channels... :(
Last time I used this box the EPG didn't even work on Freesat! only 'now and next' Useless if you wanted to record!
The Edision nino with Whooshbuild is a different story!
 
M

moonbase

Small Dish Man
Messages
2,108
My Satellite Setup
2.0m Precision
My Location
UK
Last time I used this box the EPG didn't even work on Freesat! only 'now and next' Useless if you wanted to record!
The Edision nino with Whooshbuild is a different story!

What is whooshbuild, turbo charged version of Open image? I have been using OpenVIX in my El Nino which is reasonable but have not updated it this year with a new image as the more recent images are supposed to have driver issues.

In my personal opinion the Edision El Nino is OK but it dont come close to some of the Android boxes that are available.
 
william-1

william-1

Super Moderator
Staff member
Messages
8,287
Location
Epping Forest
My Satellite Setup
OP Gibertini 100 XP+ Inverto Black Ultra 0.2
(50 east to 45 west)
TM6902HD (A/B switch) TM5302HD 1st edition

88cm Dish +Inverto Black Ultra 0.2
(53 east to 45 west)
Octagon SX88+ (A/B switch), Golden Interstar Alpha X
45cm SpiderboxHD9000 28E
My Location
Epping Forest Essex
Please keep to the thread topic "Edision Primo IP S2 Latest Firmware"

Start a new thread for "Edision El Nino" as this is a separate issue & a different receiver thank you.
 
Adam792

Adam792

Specialist Contributor
Messages
569
My Satellite Setup
Dishes: 80cm (5°W/4.8°E), 80cm (30°W), 60cm Zone 2 (13°E/19.2°E/28.2°E)
Receivers: HTPC (Intel i3 processor, nVidia Graphics, and TBS6905 4x DVB-S2 PCIe tuner card) running Ubuntu with Kodi/TVHeadend, Wetek Play2, Skybox M3.
My Location
Worcester
The Primo really needs Some updates. The subtitels in the HD Chanels wont werk properly, the teletext subs won’t record, the box sometimes doesn’t record, which means you can’t trust it to record your favourite tv show and the Kodi won’t work... I’ve called to Edision several times but they are not interested anymore in the primo... such a shame... Could be a hell of a lot better if they fixed those issues... Not that the Primo is that bad... but could be better... a lot.

At Edision, they tell me to buy the MIO 4K...

No Edision anymore for me...
I’m looking for replacement for my four PRIMO’s.
Multistream, T2-MI, Abertis TDT and E2 Chanel list should be supported, if possible also 4K, and not too expensive...
Abertis works in the modified v.62. You just bizarrely have to reboot in between scanning each transponder.

It’s a shame there hasn’t been newer software released to fix bugs as others have said. It’s a pretty good value box otherwise.
 
RustySpoons

RustySpoons

Sleepy Hollow
Messages
2,261
My Satellite Setup
50E - 30W
2x CM 1.2m Polar Mount/Jack
65E- 65W
Gibertini 1m OP100 - STAB HH100 - Inverto Black Ultra 0.2 Twin
Mutant HD51
Edision Primo IP S2
Dreambox DM800HD
Venton Unibox HD2
Sony Bravia 55" 4K
My Location
South Wales
It's a real shame, only some simple changes needed in firmware.
Interestingly the firmware on the Edision site is older than the "Modified" firmware, I wonder what firmware Edision have, has anyone asked them for the latest firmware?

I did look at finding a way to flash the Octagon firmware on to it, but the Octagon has more ram and some other changes, I know there were multiple boxes released at the same time on this platform, would be interested to see if one is more or less identical to the Edision.

The biggest annoyance for me is the way it stores satellites, you cannot manual assign it a location when using a Vbox.

Also the power supply is junk that came with the Edision, it's cheaply made, a nasty design and the capacitors will hold in excess of 200v across the mains terminals when unplugged after being powered on, be careful. If curious short them out when you have just unplugged it or measure with a multimeter. I threw mine in the bin, as it was producing a lot of interference (QRM) on the Ham bands and also the FM broadcast bands.
 
Last edited:
Lazarus

Lazarus

Tout Rond Bon Oeuf
Staff member
Messages
25,411
My Satellite Setup
80cm Motorised.
Several small Dishes.
Much else.
My Location
North York Moors
Also the power supply is junk that came with the Edision, it's cheaply made, a nasty design and the capacitors will hold in excess of 200v across the mains terminals when unplugged after being powered on, be careful. If curious short them out when you have just unplugged it or measure with a multimeter. I threw mine in the bin, as it was producing a lot of interference (QRM) on the Ham bands and also the FM broadcast bands.

Interesting. I have some interference on FM that appears on my Audio Amp situated close to the Primo.

That could be the source, then.

Will prove, in due course.
 
Lazarus

Lazarus

Tout Rond Bon Oeuf
Staff member
Messages
25,411
My Satellite Setup
80cm Motorised.
Several small Dishes.
Much else.
My Location
North York Moors
Well, it wasn't owt to do with the Primo, sadly.
 
Top