HELP - no BBC HD channels...

joddle

Specialist Contributor
Joined
Jan 12, 2007
Messages
555
Reaction score
106
Points
43
Age
73
My Satellite Setup
2x Pace 2600 C1 (in a box just in case) , 3 x Humax HD Foxstat (2 of which in store as spares) . 3x Manhatten Plaza - Pasat 2.4 PF dish mounted on flat roof with Invacom C120 quad LNB .
My Location
Massanassa, Valencia, Spain
In Spain I have a Humax Foxsat HD and there can receive everything on Freesat including all the HD channels.

Currently I am in the UK with another Humax Foxsat HD box but it seem incapable of tuning into the BBC HD channels Its OK with CH4HD and ITV HD but I get zero SS and SQ for 10847 when I try to tune in to the BBC HD channels.

If I use "manual tune" and set 1087 to 23000 and 2/3 and 8PSK - it will "see" the channels but then I don't seem to be able to look at them. What's going on? - I thought a freesat tune would do everything but it seems not to be the case.

On ITV HD I am getting readings of 100% for SS for SQ so I don't think it can be a lack if signal!

Is it a box fault or something else? - all other tps seem to be fine!!
 

Lazarus

Retired Moderator
Joined
May 29, 2009
Messages
27,105
Reaction score
8,687
Points
113
My Satellite Setup
80cm Motorised.
Several small Dishes.
Much else.
My Location
North York Moors
If I were you , I'd execute a factory reset.

That would be the best first step to take.

If the fault does not clear, then you might need a PSU Repair Kit - The Humax has a well documented propensity for unpredictable performance once the poor quality Smoothing Capacitors degrade.
 
Last edited:

Lazarus

Retired Moderator
Joined
May 29, 2009
Messages
27,105
Reaction score
8,687
Points
113
My Satellite Setup
80cm Motorised.
Several small Dishes.
Much else.
My Location
North York Moors
In the circumstances, though - ie assuming the UK box is rarely powered up, you might be advised leave it powered up for a good while after the Factory Reset as this can sometimes rejuvenate dodgy Capacitors.
 

joddle

Specialist Contributor
Joined
Jan 12, 2007
Messages
555
Reaction score
106
Points
43
Age
73
My Satellite Setup
2x Pace 2600 C1 (in a box just in case) , 3 x Humax HD Foxstat (2 of which in store as spares) . 3x Manhatten Plaza - Pasat 2.4 PF dish mounted on flat roof with Invacom C120 quad LNB .
My Location
Massanassa, Valencia, Spain
Many thanks to you guys - never thought of a reset - so simple eh! Just did that and now everything is working fine. Simples!!!! I am aware of the power supply issues and have a spare standing by which has been recapped!!!! Thanks anyway...
 
Top