Help! TWTA problem

LeeJI

Member
Joined
Apr 23, 2010
Messages
1
Reaction score
0
Points
0
Age
35
My Satellite Setup
Small Broadcaster
My Location
Singapore
Hi..I just order and received a TWTA (Travelling Wave Tube Amplifiers). When I receive it, the shock sensor (ShockWatch) on the packing shows "RED" alarm alert, which means it might experience a great turbulence/bump on handling to my post. Anyone have the same experience like this before? Is it will still perform its function fully? Is it gonna cost me impact on later days?

This is a new equipment, i haven't open the packing box yet. I have a complicated issue with the insurance and forwarder. Please do help..
 

aceb

Specialist Contributor
Joined
Oct 2, 2007
Messages
1,522
Reaction score
819
Points
113
My Satellite Setup
Prof Tuner 7301 /
1.25m Gibertini + Inverto B.Ultra/C1W, Moteck H180, 68.5E-67W Ku/C-Band /
1.8m Precision PF + ESX241/Inverto Black Pro, 66E-63W Ku/C-band /
2.4m Fortec Star+Titanium C1W/Pride plate, 49E-58W
My Location
Sussex
We used to have large glass and ceramic laser tubes shipped in from the US that had Shockwatch sensors on them, occasionally one would come in that had turned red but there were never any failures of equipment. I'd say the best thing to do is speak to your supplier and see what they suggest, no point putting them on if they don't have a procedure in place should one trigger.
 

Channel Hopper

Suffering fools, so you don't have to.
Staff member
Joined
Jan 1, 2000
Messages
32,672
Reaction score
7,414
Points
113
Age
57
Website
www.sat-elite.uk
My Satellite Setup
A little less analogue, and a lot more crap.
My Location
UK
Have a word with the courier as well, were they working on your behalf or the supplier ?
 
Top