Problems with Strong 4375 firmware 1.01 upgrade

Status
Not open for further replies.
S

Stargazer

Guest
#1
I have run into serious problems with the new software for the 4375. After the upgrade, the receiver now locks in to producing a flickery NTSC image (despite my TV being NTSC compatible, the Strong's signal is stretching the picture off the bottom of the screen, hiding half of the system menu).

I have not been able to correct this by changing any settings (even a factory reset has had no effect) and the receiver is now almost useless (cannot redo the setup without seeing the system menus).

I have emailed Strong asking for a resolution (or at least a copy of the 1.00 firmware to regress the upgrade) but would like to know if anyone has encountered anything similar. If anyone else is considering an upgrade, I would suggest proceeding with caution...
 
S

Stargazer

Guest
#2
Still had no reply from Strong on this. Was able to set the system back up (after doing a factory reset) and found something rather odd. The receiver will now not display FTA programs on digital (usually all I see is a line at the very top of the display) but *will* display channels that I could access with a FreeCAM (albeit stretched vertically and with pixellation and pausing). Analogue channels are OK.

Can anyone suggest a reason for this? Could this be a hidden plot by Strong to mess up FreeCAM owners? If I threw my receiver over to the Netherlands, what would be the chance of a working replacement?
 

2old4this

Honorary Admin
Messages
1,658
Likes
0
My Location
Cloud Cuckoo Land
#3
I have not heard of any such problems.
I assume the CAM remark is tongue-in-cheek (if not - just remove the CAM, or try a different one, to test your theory...)

Did you not purchase your receiver from a dealer? If so, why send it back to the manufacturer? Just go back to your dealer and point out that you have this thing called a guarantee and statutory consumer rights...

By the way, your problem does not sound like it is firmware related. Sounds more like a hardware problem.

2old
 
S

Stargazer

Guest
#4
Managed to get the problem sorted. I contacted Myers Audio and they sent a beta software update that they had received from Strong. Installing this appears to have fixed the problem.

The file itself is 878K (version 1.01 dated 17 Jan 2001) and I would be happy to email a copy to anyone who needs it. Better still would be to be able to download it from this site but the file upload facility is limited to 40K. Any suggestions here, 2old?

Kudos to Myers for responding and a great Bronx cheer to Strong for (seemingly) employing lobotomized zombies for their support (ie I received no reply despite the seriousness of the problem).
 

2old4this

Honorary Admin
Messages
1,658
Likes
0
My Location
Cloud Cuckoo Land
#5
You could mail it to Satnerds.
They have quite some interest in Strong receivers.

They would probably put it on their site.

Main entrance: http://www.satnerds.com/
Download section: http://www.satnerds.com/software/index.htm
Discussion frum: http://www.satnerds.com/cgi-bin/ultimatebb.cgi
Contact email address: webmaster@satnerds.com

Alternatively, upload it to one of the more geneal sites such as Digital FreeSat or sat-digital-tv.provider.pl, and publish a link here to the upload section.

2old
 
Status
Not open for further replies.
Top