atmelprg.exe?

S

szymon

Member
Messages
6
Likes
0
#1
Hey folks,

Does anyone know where I can get hold of atmelprg.exe, the dos program for programming atmel cards (such as a fun card) in an Elvis programmer? It seems to have totally vanished from adteknik's site. However, their manual still says that if you're having trouble programming a fun card, you should use atmelprg.exe. I've searched this forum (and countless others), as well as as much of the web as Google covers, and I've been unable to find it.

I have a fairly old Fun card with an AT90S8515 processor and a 24c64 memory chip, along with the typical 7 LED's. The processor clearly has some form of software on it, as I can use a phoenix programmer to program the external EEProm. I don't have a seperate fun programmer, and I was about to give up when I remembered that my trusty Elvis should be able to do this! The Elvis is an MP3.5 Firmware 1.7 (flash date 2002-04-04), and I have downloaded the latest multiprog 1.80. To ensure that Elvis is working just fine, I have written a couple of PIC cards, and I also put the 24c64 in the IC socket and read and written to it just fine. I also put the Elvis in Phoenix mode, and used that to read and write to the 24c64, and the Elvis "built in" phoenix tab also reads and writes the 24c64 just fine. The fun's data light shows it transmitting data, and it works perfectly.

However, the moment I try using the Fun/ATMega tab to do anything, everything goes to pot. Whatever I try to do, be it read, write or even erase, the programmer returns "Error Initializing Card". Even removing the checkboxes from all of Flash, Internal Eeprom and External Eeprom, and simply choosing "Identify", I get a red "Error Initializing Card" at the bottom.

This is the only AVR programmer I have available, and I'd really like to get it working on this card :) That's why reading the docs that said "if you have trouble programming an atmel card, use atmelprg.exe under dos", I figured I'd do just that. I have win98 on a machine somewhere here, and...well, damn, I can't find atmelprg.exe anywhere :-( I know it's on the original disk I got from cardman.co.uk when I bought the programmer a couple of years back, but of course I lost those ages ago...

Any help much appreciated!

-simon
 
S

szymon

Member
Messages
6
Likes
0
#2
as an aside, I'm fairly sure it's not a power problem. I've tried both with a 9V battery and with a seperate regulated 9VDC power supply (which came with my Elvis).

I'm sitting here racking my brains :S
 
S

szymon

Member
Messages
6
Likes
0
#3
So I got hold of atmelprg.exe from the web archive (what a wonderful place). However - I still can't program this card! After atmelprg.exe finds the multiprogrammer and identifies it correctly on com1 etc, it says:

Searching for Atmel chip...
Sync SPI...FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF
Bad chip, impossible to sync. SPI connection with chip

__User Abort__

So, is my AT90S8515 really fried? It seems a bit strange, as I can program the external Eeprom via phoenix just fine...what's going on? And how do I fix it? :-)

Cheers,

-simon
 
S

szymon

Member
Messages
6
Likes
0
#4
I guess by the number of answers I've got so far that there's not too many folk on the forum familiar with the technology for the section on "cards & programmers general". oh well :)

Turns out that the fun card is wired up for DPL, which is why I can program the external Eeprom using phoenix mode. I guess that means that the AT90S8515 is fried and that's all there is to it then. *sighs*

-simon
 
S

szymon

Member
Messages
6
Likes
0
#5
Has anyone ever actually used an Elvis MultiProgrammer (from adteknik) to program a fun card?

I've just tried a totally different fun card, one that I *know* is working, and I can't even identify the card - symptoms as above.

Help!

-simon
 
S

szymon

Member
Messages
6
Likes
0
#6
So I just spent some time on ICQ with the guys from adteknik - excellent technical support I must say. I've included a copy of the conversation below, for those who are interested. It turns out that the fun cards I have are of a very old type, and simply don't have the connections necessary for SPI - so I can't program them via the ISO interface. Hilarious :-)

(11:06:56) Simon: Hello there, I have a couple of questions about your multiprogrammer if you have time
(11:07:44) Simon: I have a 3.5 with firmware 1.7, and I am having trouble programming fun cards. At first I thought it was possibly a program with my card, but the card itself works just fine. I've also (yesterday) just tried another fun card, with exactly the same problem
(11:09:19) adteknik: Hi! Try our test software called MP_Test... There is an I/O-pin test function in this program. If this test reports an error there could be something wrong with your programmer
(11:10:32) Simon: I've done the MP_Test, and it checks out just fine
(11:10:59) Simon: it also seems able to program pics just fine, both on a card via the iso interface and directly
(11:11:29) Simon: I can even use the 'phoenix' tab on mp8 to read and program the external eeprom on the fun card
(11:11:55) Simon: however, I get 'error initialising card' when trying to use the 'fun/atmel' tab to do anything, even identify
(11:12:27) adteknik: ok, in this case it could be something wrong with the smartcard reader itself. Funcards is a bit special, they use more connectors of the reader than other cards when programming the AT90S8515 chip.
(11:13:03) Simon: aha. Is there any way of confirming that?
(11:13:05) adteknik: Also make sure that the connectors of the smartcard is clean
(11:13:28) Simon: I've tried two seperate smart cards, and I cleaned the connections carefully
(11:13:51) Simon: it's strange - when I put the programmer in phoenix mode and then use phoenix software, I can get the card ATR
(11:14:02) adteknik: No... But since you can program other cards and the external eeprom, then the problem must be with connector C4 or C8 on the smartcard reader.
(11:14:51) adteknik: You will not need connector C4 or C8 to receive an ATR from your card. However, your card must be already programmed.
(11:15:08) Simon: indeed - the cards aren't blank, they have been programmed before
(11:15:29) Simon: should I be able to test the connection of C4 and C8 with a simple multimeter?
(11:17:01) adteknik: It's difficult because you cannot reach the smartcards connectors while the card is in the reader. Make a visual inspection of the reader to make sure that it is allright.
(11:17:45) adteknik: if you look into the opening of the reader C4 and C8 are the two connector on the right
(11:18:19) Simon: the reader "seems" fine. I've looked after the programmer, even though it's two years old. I've just never tried to program an atmel based smartcard before (most of my previous work has been directly programming PICs for various projects).
(11:18:22) adteknik: (one in the front row and the other in the back row)
(11:19:18) Simon: ok, those look fine, and they have a perfect connection to the board - no cold solder or anything
(11:19:47) adteknik: ok... btw have you enabled the "fast write" settings in Multiprog? This may not work if you have an old firmware in your programmer
(11:19:51) Simon: I'll see if I can put together a season interface and write a little program to check each of the pins
(11:20:14) Simon: I've tried both with and without the 'fast write', I also downloaded the old dos atmelprg.exe from an archive of your old web site and tried that
(11:20:34) Simon: it comes back with SPI error (which I guess is the serial programming interface of the atmel processor)
(11:21:53) adteknik: ok... it seems that you have tried your best to get it going... It would appear that it could be something wrong with the programmer unless there is something wrong with all your funcards (which is unlikely)
(11:22:30) adteknik: I would suggest that you send the programmer back to us for a repair so that we can sort this problem out for you.
(11:22:37) Simon: hehehehe, I've just realised what it is
(11:22:48) Simon: this is a funny solution that I'd never have found without your help :)
(11:23:08) Simon: the fun cards I have, neither of them have a connection for pin C4 and C8!
(11:23:09) adteknik: ok... what was wrong?
(11:23:21) Simon: they only have 1,2,3,5 and 7
(11:23:38) Simon: so I guess it would be impossible to program them using the SPI interface of the atmel programmer :)
(11:24:01) Simon: which is correct - the processors were originally programmed using a funprog with a zif socket
(11:24:22) adteknik: Strange, in this case they cannot be programmed with the programmer. Perhaps you need to remove the chips for programming in this case.
(11:24:34) Simon: thanks very much for your help - now at least I know that the programmer is functioning correctly, and that I can go and get some slightly more modern fun cards!
(11:25:11) adteknik: :-) Yes, these funcards seems like the earliest type of them
(11:26:01) Simon: they are. I am programming them for a friend who wants to do something funny with Polish satellite television with them - he's provided me with .hex files with the programming, and I told him I'd fix it :-)
(11:26:07) Simon: thanks again for your help - much appreciate it!
(11:26:47) adteknik: ok... thank you very much, glad I could help... bye bye!
 
Top