• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Attempt to flash via CF - help

My Satellite Setup
DM 7020s
My Location
I am new to the hobbie, so please excuse the ignorance. Since I do not have the capability of connecting my 7020 to PC via network or other cable, I tried to do a flash to the new Gemini 2.50 from the existing Hydra 1.09 via the CF card. I did everything by the book i.e. copied the files to a freshly formated CF card, unluged all cables from DB etc. etc. I switched the machine on, it recognised the card existence, asked me nicely whether to flash or not - I said yes - then it showed the screen "Loadind... this will take a while" and, I am still waiting..... DB is refusing to move on. I stared the screen for more than half an hour, I tried files from other sources, I even used another card, but nothing: DB stays for too long on this screen, without moving on.
Does anybody have any ideas?
Best Regards to all


Regular Member
My Satellite Setup
dm 7000 and 7020
cas 3
blue ice cam
sv card
redlight card
seca cam
reality cam
opos 1.03 and 1.05
lynksys router
gold cards
fun cards
1.1 mtr trix dish
0.3 sharp lnb
hh100 moter
xplus tv and inxtc card
s_x view +
ceribro card
My Location
just above the earth
try d/l from a diffrent place the file sounds corrupt then reflash your cf and try again