• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Help Reqd on Humax 5300

J

JohnK

Guest
#1
Hi

I have a Humax 5300 with embedded Viaccess, I got a new card yesterday and everything was fine until I took out the card and put in another card for another service, after that the STB keeps giving me the message "Invalid Card" for both cards even though both worked previously, any help would be appreciated.

Thanks

JK
 
Messages
15
Likes
0
#2
Hi John,
I would remove the card and depower and re-power your receiver. Try cleaning the card contacts before re-inserting it. Make sure the card contacts are facing upwards.
The only other thing is to check your card is staying all the way in the slot. My 5300 alows the card to move forward and needs a small piece of card pushed in below the viewing card to keep it in place.

I hope this helps.

Nig.
 

Channel Hopper

Suffering fools just so you don't have to
Staff member
Messages
23,958
Likes
5,001
My Satellite Setup
A little less analogue, and a lot more crap.
My Location
UK South East
#4
Does the Invalid Card message come up even if the card is not in the box ?

What type of card was it ? Legit ?
 
J

JohnK

Guest
#5
Hi

No the message only comes up when I put the card in, it's an official card so there should be no problem, I got it yesterday and it worked fine until I removed it and put in another official card, after that none of the them are working and I keep getting the Invalid Card message when I try the 2 cards I've got, I'm not sure if the problems lie with the cards or the STB which is a Humax 5300 with embedded viaccess

Thanks

JK
 

Channel Hopper

Suffering fools just so you don't have to
Staff member
Messages
23,958
Likes
5,001
My Satellite Setup
A little less analogue, and a lot more crap.
My Location
UK South East
#6
You may have to enter the Humax website and force a firmware update.

Try leaving it on the satellite channel thats receiveable by the card overnight, it may be that they will authorise the card while you sleep

I did hear of some problems with the older late night cards causing trouble when removed before powering down the receiver
 
J

JohnK

Guest
#7
Hi

Following on from the above saga I received replacement cards today and everything back to normal, however stupid question time, is there a correct/incorrect way of putting cards in and removing them from a receiver as I've obviously done something that's rendered my last cards as useless when all I did was remove one and replace it with the other? Are you supposed to switch the receiver to standby or something, any advice much appreciated as future replacement card would cost me £25 (Rip Off).

JohnK
 

Channel Hopper

Suffering fools just so you don't have to
Staff member
Messages
23,958
Likes
5,001
My Satellite Setup
A little less analogue, and a lot more crap.
My Location
UK South East
#8
No reason for damage as cards are supposed to be hot pluggable. It could be a problem with the power supply or possibly a fault int he connections to the card reader, but this is less likely