• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Invacom C120 output universal lnb question ?

Messages
55
Likes
0
My Location
pj::
#1
Hello Everybody.
Would someone please tell me if the 2 outputs on the Invacom twin output universal are seperate outputs or 2 of the same.

I fitted one of these a few months ago but only yesterday got around to fitting the second cable which I ran to a room upstairs.
However when I connected a sat meter it said that there was no signal present.I am pretty sure that i made the connections correctly using new cable.
The first cable runs to my Echostar 7000HDD downstairs.
I connected the second cable to a Nokia 9600 upstairs but got as I said no signal.
The Nokia had previously worked fine downstairs being fed from a Global four way active splitter.
Has anyone come across a problem with the Invacom twin output universal lnb's.
Regards.
amdaley.
 

rolfw

Believe it when I see it Admin.
Staff member
Messages
37,652
Likes
1,272
My Satellite Setup
See signature
My Location
Berkshire
#2
A twin LNB will have two identical outputs, try reversing the connections at the LNB and see what happens.
 
Messages
55
Likes
0
My Location
pj::
#3
rolfw said:
A twin LNB will have two identical outputs, try reversing the connections at the LNB and see what happens.
Hello rolfw.
Thanks for that. Got it sorted this afternoon. The problem was at the lnb connection. The centre copper core of the coax cable wasn't making proper contact. Once I remade the connection it was fine.
Regards.
Tony. :-righton
 

rolfw

Believe it when I see it Admin.
Staff member
Messages
37,652
Likes
1,272
My Satellite Setup
See signature
My Location
Berkshire
#4
Ah the old short core problem. :D Glad you got it sorted Tony. :)