Lacuna Sky meter

Messages
8
Likes
0
My Location
Sheffield/UK
#1
Hi

I am hoping that someone has come across this problem or knows where i can get help.

I have a Yelow Lacuna sky digi sat meter2002 model, i haven't used the meter for around a year or so. i wanted to use it the other day and had to purchase a charger because i had lost the original.

when i connect this charger although it is not made specifically for it, it is a 15V regulated power supply at 2500mA which should be ok.

well here is my problem, it seemed to be charging ok, the display showed first trickle charging then boost charging. i left it for several hours so i assumed it would be fully charged.
now when i switched the meter on it showed 89% charged then within less that a minute it was at 45% then it just kept falling until it swiched off.

i have tried recharging it again but now it just switches on, displays the model and software version then searches for a satellite and then switches off.
i am not sure is it the batteries that have gone or something wrong with the meter. anyone who can shed any light on this would be most appreciated.

Alabadi
 

rolfw

Believe it when I see it Admin.
Staff member
Messages
37,700
Likes
1,287
My Satellite Setup
Technomate 5402 HD M2 Ci, DM7000s, Transparent 80cm Dish, Moteck SG2100 DiseqC motor, lots of legacy gear. Meters: Satlook Digital NIT, Promax HD Ranger+ spectrum analyser.
My Location
Berkshire
#2
Could well be the battery pack which has died, they don't like being left that long..
 
Messages
8
Likes
0
My Location
Sheffield/UK
#3
Yes Rob i think that that is the problem myself, but i wanted to be sure before i go and dismantle the meter to replace the battery pack.

thanks for your comments
 

nopfusch

Regular Member
Messages
40
Likes
0
My Satellite Setup
sAT.: EechostarDVB 1000Ci2 (no 7 tears old and faulty), one Analogue receiver threshold -3dB, even older but still in good working order, 3.6m mesh dish with positioner, California feedhorn with mech. polarizer and C- and Ku- Band LNBs.
PC1 P4 2.2GH
My Location
South Africa, Johbg., 26.2S, 28.1 E
#4
Hi alabadi,

definitely it's the batteries. Repeat the procedure charging - discharging. If the on-time of the batteries increase, then carry on. On the contrary if the on-time gets less, replace the batteries. Watch out, that you use the same type , e.g.

Ni-Ca (Nickel-Cadmium) or whatever type is installed.

Good luck.

nopfusch
 
Messages
8
Likes
0
My Satellite Setup
Star Choice in Western Canada.
KA Frequency Broadband Internet
AMD Athlon 3200
1 gb Ram
250 G HDD
256 mb ATI 9600xt
DVD Burner, etc, etc.
My Location
Western Canada
#5
Not much Dismantling involved, Just two Screws
 
Messages
12
Likes
0
My Satellite Setup
lacuna , mk2
My Location
ireland
#6
hi , i have a lacuna sat meter. when i connect it to the sat. cable and i turn it on, just 000 showed, and shutting off. I can charged it but he wont work....just comming up searching and i can switch between the satellites.Also at the tunner part is heating up
, please help. Thanks
 
Top