mm re-programming

T

tivadar

Guest
#1
On the suggestion of Rolf, (Toecutter,s Den) I would like to
ask the opinion of Nikolai, over the following problem:

(Nokia 9800S, MM 1.02, Pentacrypt 1.07)

(1) Have programmed succesfully the MM first, by flashing it
from PW to Canal+, then Stream, the picture disappeared

(2) Tried to reboot, many times, failed.

(3) The Penta disappeared from the screen too, therefore I
wanted to re-program again the MM first, then reintroduce
the smartcard (Fun 4, Boris 6in1 and Xamuh 6in1)

(4) There is no display for CAM modes on Nokia, but
I did both ways to get back to Dreamload mode:

- retrieved and reinserted the MM without card
three times;
- with MM in the slot without card, shut down the
receiver three times and restarted

(5) Tried then to re-program, with the same PC, same
serial cables, same loader.

(6) The dialog box of the loader keeps repeating
"unable to connect to module" and the green/red
LEDS on the programmer are dead

(7) Checked the cable and the comports several times,
(brand new cable, perfect connections): looked
perfectly good, as in the first time.


Seems to me, either the programmer, or the MM, or their
compatibility to the Nokia are the problematic points.

I would appreciate very much to have your comments.

Many thanks in advance for your attention.

All the best, tivadar
 

Nickolai

Regular Member
Messages
97
Likes
0
My Location
Berkshire
#2
Hi, Tivadar

The problem you are describing is most likely related to the infamous "PentaCrypt 1.07 reverting to DreamLoad" issue.
I must admit I only heard of it with association to Echostars, but it sounds likely it's there with the Nokia's too :mad:

Pentacrypt 1.07 may occasionally revert the module to the "frozen" state: CI info menu shows Dreamload or nothing, no channel decrypts and the module is extremely difficult to reload or reset properly.

Unfortunately, a 100% solution has never been reached for this one.

The following was claimed to resolve the issue:

THE BUG:
After you have programmed the module and you switch off the receiver the mm returns spontanley to dreamloader. The same problem occurs, when the receiver resets (this happens, for example, when you try to watch a channe,l but you don't have the right keys and the receiver returns back to the last viewed channel).
I have found two solutions:
First solution
- when switching on the reciver go to cam menu: it shows "Dreamload".
- insert the programmer into the MM. The light, on the programmer, becomes green, then wait few seconds
- remove the magic programmer from the MM
- the written to cam menu shows, after few seconds, first "no module inserted" and after PENTACRYPT 1.XX
- Now the mm works normally
- Reset the MM according to the normal procedure and reload with PentaCrypt 1.05
Second Solution
- go to cam menu, it shows "Dreamload".
- press on the telecomand "VT" tast. (not sure about this one - Nickolai)
- on the cam menu you can see, after few second, no module -PENTA 1.XX
THAT'S ALL
if sombody can resolve this bug with a firmware please contact me--- THANKS...
Raystr
Posted: 08.09.2002 - 16:44 Post subject: Magic Reset!
--------------------------------------------------------------------------------
Yep, I have had the same problem, it reverted to Dreamload.
I thought, that the solution was to clean (reset - N. ) the mm but this failed.
I was just about to send the bloody thing back, when I was saved - the following did it for me.
Power down the receiver and unplug the module. Replace it with the original cam, then power up. Do the same thing again, but put the mm back in - hey presto! it works.
Hope this helps!
The above suggests that something maybe going wrong with the CI slot itself: I just replied to the post in Tony Doe's forum where one bloke managed to fry his Echostar CI slot 1 by frequently reloading the MM (the Echo stopped initialising other CAMs in this slot). :confused

If the above does not work for you, I would suggest borrowing somebody's laptop (Win 95 or Win 98), as a last resort.
When the module is powered by the laptop, one has very rare connection problems :) .

Let us know, how it goes!!
 
T

tivadar

Guest
#3
Many thanks for your kind assistance, Nikolai aand Raystr.

Will proceed as told.

All the best, Tivadar
 
T

tivadar

Guest
#4
Dear Nickolai,

tried both of your suggestions, still not working.

I have had a laptop just a short time ago, AND THAT
STILL NOT WORKED. !!!

I inserted the MM into the PCMCIA slot of the Compaq laptop
inserted into the MM the programmer, with a serial cable
connected to my PC and to comport.

The leds still not on, neither the green, nor the red.
The laptop did not react to the MM AT ALL!!

The dialog box again refused to trasmit the file,
with the usual "unable to connect to the module":


I attempt now to copy the software to a CD, and from
the CD through the laptop try to reach the module.

Would you be kind enough to check on above, I have written
if I am doing the right thing.

Many thanks in advance

best regards Tivadar
 

Nickolai

Regular Member
Messages
97
Likes
0
My Location
Berkshire
#5
Tivadar,

sorry to hear about your troubles.

Now, the laptop thing is worrying me - if the PC is powered on and you insert the module, it should sense that a new PCMCIA device has been added and attempt to install the driver, which you should have put into the system beforehand.

Without the driver the module will not power on.

See FAQs (progamming with the laptop and where to get magic module software).
 
T

tivadar

Guest
#6
Dear Nickolai,

I tried with Compaq laptop. operating system Windows 2000.

It says "initialization is wrong" . The laptop did not recognize
the module, at all !!! It is true, though, it did not recognize
the Aston and Irdeto cams either""

The only problem I can think of, that the driver I installed
was based on a Windows 95/98 system.

Can that be? Or should I just send back the module and programmer to the supplier, who are ready to replace them?

Many thanks for your attention,

Tivadar
 

rolfw

Believe it when I see it Admin.
Staff member
Messages
37,699
Likes
1,287
My Satellite Setup
Technomate 5402 HD M2 Ci, DM7000s, Transparent 80cm Dish, Moteck SG2100 DiseqC motor, lots of legacy gear. Meters: Satlook Digital NIT, Promax HD Ranger+ spectrum analyser.
My Location
Berkshire
#7
I think that you've hit the nail on the head Tivadar, win 2000, NT and XP won't work with the CAMs, I think even ME doesn't work.
 
Messages
6
Likes
0
My Location
Nottingham
#9
Originally posted by rolfw
I think that you've hit the nail on the head Tivadar, win 2000, NT and XP won't work with the CAMs, I think even ME doesn't work.
Hi,
My pc`s system is XP and I am just about to buy a Magic Module ( subject to availability ) so after reading your comment should I forget the idea. What`s the alternative?

Regards, Wrinkly.
 
T

tivadar

Guest
#10
Please, have a look on the posts of Nickolai on this site
(Magic Module) with detailed instructions, how to proceed.

With a laptop definitely only Windows 95/98 can programm
the MM.

All the best
Tivadar
 
Top