mVISION hd200 Receiver locked

bri1uk

Member
Joined
Feb 17, 2010
Messages
4
Reaction score
0
Points
0
Age
54
My Satellite Setup
Mvision HD-200 Receiver with 80cm dish and Disque motor
My Location
Gloucestershire
Hi can anyone help a newbe please

My Mvision HD200 reciver seems to be locked, when you turn it on from the switch on the back only a green light comes on there is no red power light or display and the stanby button does not activate it.

I have tried all the buttons on the front and all the remote buttons but i can't seem to get it to come back to life

Any sugestions please?
Thnks Brian:confused
 

Topper

Amo Amas Amant Admin
Staff member
Joined
Nov 18, 2004
Messages
23,829
Reaction score
3,912
Points
113
Age
67
My Satellite Setup
Has gone to a good home elsewhere
My Location
Blackburn, Lancashire
Hello

Welcome to the forum bri1uk

Well it sounds like your Power Supply Unit may have gone down especially if the red power LED is missing , how old is the unit?
If still in warranty the repair should be FOC. Where did you buy it from?
 

bri1uk

Member
Joined
Feb 17, 2010
Messages
4
Reaction score
0
Points
0
Age
54
My Satellite Setup
Mvision HD-200 Receiver with 80cm dish and Disque motor
My Location
Gloucestershire
Hi thnks for the reply, sorry it has taken so long to repond too.
I puchased the receiver from Ebay on the 30.9.2008 so i think it will be out of warrenty.
If it is the power unit that has gone could you tell me why i am getting the green light on the front?
I thought had it of been that i would get No lights at all.
Regards Bri1uk
 

adonis1

Specialist Contributor
Joined
Mar 2, 2008
Messages
1,535
Reaction score
1,464
Points
113
Age
66
My Satellite Setup
Gibertini dish 1.55 Χ 1.66 ( 100.5°E -45.0°W) ku lnb Inverto Black Ultra 0.2db - Ku band Circular Uni Inverto BLACK Pro 0.2db / / C-Band lnb Titanium wide band - Pauxis 13°- K Panorama 13°K
DR.HD F-15 - Openbox S11 HD - TM-5402 HD M3.
My Location
Syros island - Central Aegean sea - Greece
bri1uk said:
when you turn it on from the switch on the back only a green light comes on there is no red power light or display and the stanby button does not activate it.

Try to disconnect any usb device or hard disk from the receiver.
 

Topper

Amo Amas Amant Admin
Staff member
Joined
Nov 18, 2004
Messages
23,829
Reaction score
3,912
Points
113
Age
67
My Satellite Setup
Has gone to a good home elsewhere
My Location
Blackburn, Lancashire
bri1uk said:
when you turn it on from the switch on the back only a green light comes on there is no red power light or display and the stanby button does not activate it.

Sorry I misunderstood I assumed you meant the kind of green on/off button that lights up indicating there is power when switched.
as in this -http://www.crazypc.com/products/82396G.html

You mean a green LED on the front lights up I assume.
 

bri1uk

Member
Joined
Feb 17, 2010
Messages
4
Reaction score
0
Points
0
Age
54
My Satellite Setup
Mvision HD-200 Receiver with 80cm dish and Disque motor
My Location
Gloucestershire
Yes sorry i should of made it more clear.
I have taken the front cover off the receiver and there are two LEDS underneath, on the circut board there is 1 Green that says lock under it and then there is the Red power LED.

When you switch the receiver on from the main rear switch only the Green LED comes on,
i thought there might have been some sort of parent lock or pin that needed to be entered to reacivate it, but i don't think that is the case now.
Regards Brian
 

Topper

Amo Amas Amant Admin
Staff member
Joined
Nov 18, 2004
Messages
23,829
Reaction score
3,912
Points
113
Age
67
My Satellite Setup
Has gone to a good home elsewhere
My Location
Blackburn, Lancashire
bri1uk said:
If it is the power unit that has gone could you tell me why i am getting the green light on the front?
I thought had it of been that i would get No lights at all.

Power supplies often contain multi-tapped transformers that provide all the different voltages that may be required by a piece of equipment. Thus one part of the system can still be working and hence an LED lighting up whilst another is not. If you are used to componants and circuits and are aware of the inherent dangers of stored capacitance charges it may pay you to inspect the componants you can see, to check for swollen or blown capacitors which are often the cause of failures. Failing that try to find a local electronics shop who will do it for you.
 

bri1uk

Member
Joined
Feb 17, 2010
Messages
4
Reaction score
0
Points
0
Age
54
My Satellite Setup
Mvision HD-200 Receiver with 80cm dish and Disque motor
My Location
Gloucestershire
Thanks for your help with this problem, i am going to take it in for the repair.
 
Joined
Feb 26, 2010
Messages
1
Reaction score
0
Points
0
Age
44
My Satellite Setup
MVision HD200 Combo
Targa Ultra AN64II 3700II, Windows 7 Ultimate
My Location
York, UK
Hi, I have the exact same problem and I would like to know if you managed to get it repaired and how much it was...!!

Thanks!
 
Top