Advice Needed No signal

cctvfitter

New Member
Joined
Jul 20, 2014
Messages
3
Reaction score
1
Points
3
Age
61
My Satellite Setup
Sky / freeview
My Location
Huddersfield
Ok so i got an Amstrad Sky plus box off freecycle when i connect it up it shows no signal on both inputs . The dish is ok and when i connect another fta box it works ok , with good signal strength.
Im wondering if there could be a problem with the sky box not powering the lnb?
Tried changing settings to no avail, of course the box maybe faulty after all i didnt pay owt for it!
Just like to know before i rip the hdd out for ebay!
 

Analoguesat

Administrator
Staff member
Joined
Jul 26, 2003
Messages
50,957
Reaction score
11,402
Points
113
Location
Scottish Borders
My Satellite Setup
TM 5402HD
Sky+ UK.
My Location
Scottish Borders
Pop the top off and have a good look at the capacitors, especially the ones round the power supply input. Any sign of bulging or leaking suggests the capacitors are shot. Not uncommon on Sky boxes of a certain age

Keep you fingers well clear of the circuit boards - the electronics can store enough power to really spoil your day....
 

cctvfitter

New Member
Joined
Jul 20, 2014
Messages
3
Reaction score
1
Points
3
Age
61
My Satellite Setup
Sky / freeview
My Location
Huddersfield
Thanks ,will have a look.
 

satelliteman

Administrator
Staff member
Joined
May 7, 2007
Messages
12,039
Reaction score
387
Points
83
My Satellite Setup
See signature
My Location
Northants, Midlands UK & Lanzarote, Canary Islands
Amstrad.... could also be a tuner fault.

Sent from my Galaxy S4 GT-I9505 using Tapatalk Pro
 

Huevos

Satellite Freak
Joined
Sep 11, 2008
Messages
6,038
Reaction score
1,277
Points
113
My Satellite Setup
57E to 58W, C-band and Ku, DVB-S2, 4:2:2 and blindscan.
My Location
38.5ºN, 0.5ºW
Or... just check in the installer menu under LNB setup that LNB power and 22kHz are switched on.
 
Top