Ooops - What's wrong now

richardinalex

Regular Member
Messages
59
Likes
0
My Location
Alexandria, Egypt
#1
Hiya chaps

Things were hunky dory here in the summer - all the Sky stuff I wanted (but not 2D here in Alexandria on a 2.7m local dish and strange LN:cool: - and we were picking up channel 4 (what great cricket) and 5 though!

Went home and bought an Invacom LNB - no better no worse - oh well.

Anyway - main reason for post - yesterday lunchtime - lost SKY - "no sat signal" message. After messing around with turning on / off / changing primary transponders etc I can now get sound on a few channels - but no picture. No Listings, in fact not too much at all. I can't add channels either - but signal strength / quality seems OK.

Its an old Grundig box by the way.

Any ideas


Cheers
 
O

Old Fred

Guest
#2
richardinalex said:
Went home and bought an Invacom LNB - no better no worse - oh well.

Its an old Grundig box by the way.
Sounds like you need a Grundig PSU kit (forget who does these - try a Google search).

Other than that, check anything you disturbed - such as the LNB clamp. Maybe the new LNB has gone faulty?

Fred
 

Old Satellite

Specialist Contributor
Messages
458
Likes
0
#3
If it is a GDS 200/300 it is most likely to the the Capacitors in the power supply,

it is an easy fix for any local tv repair shop mostly, or if you have the skills you can replace them yourselves. but please ensure that you change them all.

They are normal common values 220,470,1000 etc etc

Cost should be less than 50 quid for a repair and only a couple of pounds from a Rs components or maplins etc.

good look

regards

Old Satellite
 

richardinalex

Regular Member
Messages
59
Likes
0
My Location
Alexandria, Egypt
#4
Good news - used the old "unplug it and leave it" technique - worked a treat.

Is this just a temporary cure? - Its been OK for the last two days!

Thanks for the other advice though.

Richard
 

frassle

Non-Activated User
Messages
38
Likes
0
My Location
Cyprus
#5
richardinalex said:
Good news - used the old "unplug it and leave it" technique - worked a treat.

Is this just a temporary cure? - Its been OK for the last two days!

Thanks for the other advice though.

Richard
I have to say that I have stopped using the Grundigs as they do not seem to like the varying signal level, it upsets them and then you need to go through all this power up and down nonsense.
 
Top