'Removed Service' solved

BGonaSTICK

BGonaSTICK

Retired Moderator
Messages
5,145
Likes
0
My Satellite Setup
Dreambox 7000, Skystar2
My Location
Brighton
#1
If anyone is interested, here’s the answer.



Please let me know if you find this useful, as I'm never sure whether it's worth my while writing all this stuff up. May be of general interest as well.



This relates to channel listings by satellite. Instead of listing the satellite name, it lists 'removed service'.



I'm pretty sure that this is the answer to the 'removed service' channel problems as well.



OK from the top.



Fact - Your satellite configuration is defined in one of two places. It’s either in 'file x' (whatever it’s called, and which I can't be bothered to track down ATM) OR it's in /var/etc/satellites.xml.



If you have both, I don't know which will take preference, though I suspect it's satellites.xml.



Base 1.08.2 Enigma does not have a satellites.xml file.

If however, you were to have this image in flash, and add another image to USB with FWP4.5 etc. and check the option 'SmartSettings Copy from active image’ it can cause a problem, as it did for me.



FWP will generate a bouquet/channel list from the active image (base Enigma, in this case), but it will not rebuild a matching satellites.xml file, which is pre-existing in both Zeus and Gemini (for example).



‘Removed Service’ appears when you have scanned a transponder which does not point to a valid satellite definition in the satellites.xml file (if it exists at all).



I suspect that you will also get this if you have a channel with no matching transponder in satellites.xml, but I don’t want to get into this. Go play if you’re interested.



OK, here’s where it got out of step for me, and why.



Base Enigma in flash, v1.08.2. Scanned all my favourite sats, including Intelsat 707 (10-02), Thor 2 and Thor 3 co-located at 0.9W.



Added Zeus to USB, and checked ‘SmartSettings’ in FWP4.5b.



Everything was cool, except no Intelsat/Thor satellite listed.



Angry.



All Intelsat/Thor channels listed under ‘removed service’ which equated to 0.9W.



Investigated. Found satellites.xml file in Hydra’s /var/etc/ to be out of step with scanned channels 'SmartCopied' across (the satellites.xml file was loaded as part of the Hydra image, and not rebuilt by FWP).



It had Intelsat 707 listed at 1.0W, and Thor2 and 3 at 0.8W! No reference to 0.9W!



Merged and de-duplicated the two lists of transponders at 1.0W and 0.8W, and redefined them as being at 0.9W and FTP’d it back. FIXED!



Also had a similar problem with Gemini in USB. Here I did not use SmartSettings copy. I had deleted 7W from the satellite list when I first set the image up (and this was obviously used to build Gemini’s initial satellites.xml file), but then later on I wanted to scan it. Couldn’t do an auto transponder scan, as no 7W listed in drop-down! Did a manual transponder scan. Cool. Got channels. Went to channel listing by satellite. ‘Removed Service’. ArrrGGGGhhh.



Same problem. No 7W in Gemini’s satellites.xml file.

Copied it from another .xml file I had, and pasted it in. Patched it up and FTP’d back. Sorted.



The list of satellites displayed when you hit the up/down button, then green, has it’s names taken from the labels defined in satellites.xml, so you can rename them there with no ill effects. Also, regardless of which order they are in the satellites.xml file, the channel/sat list on the Dreambox is dynamically sorted in alphabetical order, so you can rename them in a specific way to have them ordered as you like.



Hope this makes some sense.



Take a backup via FTP. Get an xml editor and have a play. FrontPage works fine.



STICK

P.S. I'll 'unstick' this thread after a couple of weeks. Just wanted to give folks a chance to read it.
 
H

haggard

Regular Member
Messages
467
Likes
0
My Satellite Setup
7000S - 300GB Maxtor
1GB USB -
Syslink wifi bridge from DB to Syslink wifi router to Apple Extreme streaming relay to Apple G5, 2 xG4.
Elgato into G4 17 in for Apple DVB-T captures.
Panasonic 42 HD ready
My Location
NW England
#2
BGonaSTICK said:
If anyone is interested, here’s the answer.

P.S. I'll 'unstick' this thread after a couple of weeks. Just wanted to give folks a chance to read it.
Top class
Read, partly understood, printed, filed in my don't lose folder and placed in section to work thru at first opportunity. Hopefully this w/e.
 
john_graydon

john_graydon

Regular Member
Messages
2,219
Likes
3
My Satellite Setup
Azbox premium HD+,Dusty Dreambox 7000s,& Sky HD.
My Location
Dublin....Ireland
#3
haggard said:
Top class
Read, partly understood, printed, filed in my don't lose folder and placed in section to work thru at first opportunity. Hopefully this w/e.
Yes same happened to my thor as well, all this only happened when the hydra panel was updated with the new file. Im going to start from scratch again clearing out everything and omitting the hydra images uptil one comes out with the new control panel on it.
 
J

jonnie666

Regular Member
Messages
24
Likes
0
#4
great explanation stick the removed services problem has been troubling my little brain cheers . ps im also giving up on zeus until a new image with control panel is released im having to many probs with it lately prefering gemini or sf image
 
gameboy

gameboy

Ding Dang Doo
Messages
4,305
Likes
5
My Satellite Setup
DreamBox 7000s - Nokia Freeview - Several GameBoys - DS Lite - ZX81 - SNES - N64 - Saturn - Dreamcast - PlayStation - PS2 - Gamecube - PSP - iPod - iPhone - XBox - PS3 - Wii - iPad - No Life!
My Location
Scotland
#5
jonnie666 said:
im also giving up on zeus until a new image with control panel is released
Zeus control panel works OK.

Updates regular - it has been updated today!

Marys has gone - don't know what new services she opened - if any.
 
J

jonnie666

Regular Member
Messages
24
Likes
0
#6
the control panel udates fine marys did nothing but freeze the box or refuse to install with the usual var to full prob with 128mb free on usb
 
RedDevil_UK

RedDevil_UK

Retired Mod
Messages
1,761
Likes
34
My Satellite Setup
Dreambox 7000S, VU+ Solo2, 1.1m Dish, Moteck SG-2100A DISEQC Motor
My Location
Rochdale
#7
when i put on the new images with FWP, i had the same problem, no 1w??
after looking into why i found out this works


i went into setup > satellite configuration

scrolled down untill i found the 0.9 (or 0.8, depending on image)

clicked OK then scrolled down to 1.0w then clicked OK

green button (save)

done, satellite went straight to 1.0w and all my favourites worked again :)
 
S

satdown

Member
Messages
3
Likes
0
#8
This has been pissing me off for ages, thanks for the explanation.

By the way I flashed the base 108.1 image at the weekend(erase twice then flash then flash erase with no cables connected other than null modem) and before any scanning or even the USB connected, I got lots of "removed service" on a menu, I can't remember which colour button(satellites providers bouquets etc).
I don't understand why, perhaps satellites are removed, because I don't use disecq - I position the dish with an old analogue pace mss508ip I.E. configured as "multi satellite via disecq" with disecq disabled.
 
BGonaSTICK

BGonaSTICK

Retired Moderator
Messages
5,145
Likes
0
My Satellite Setup
Dreambox 7000, Skystar2
My Location
Brighton
#9
Hey, pleasure.

I position my dish with a Skystar2 PC card, but I set my dreambox up as if it had a DiSEqC motor, and I've found this to work OK. Not tried it any other way.

When I switch the Dreambox to a channel on a different satellite to the one it's on, I get the 'Motor turning to 13E' or whatever message for a second or three until it realises it's already there (it obviously can't tell I've just run upstairs to the PC and moved it!) and receiving a signal, but no more 'removed services'.

Maybe if you have yours set up as if it's using DiSEqC 1.0 switch (or no DiSEqC at all), it knows it can only have four/one satellites actually configured, even though that's obviously not the reality?

Try it the way I have it, and see if it makes any difference. Let us know how you get on.

Basically, you probably just need a new or modified satellites.xml. Have a look at it and see if it tallys with all the 'removed services' you see on the menu(s).

STICK
 
S

satdown

Member
Messages
3
Likes
0
#10
Haven't tried this and was reluctant to do it, because I didn't know whether sending electric shocks up the line could have a detrimental effect on the LNB.
Obviously you don't have a problem, so I'll give at a go next weekend and report back.
 
BGonaSTICK

BGonaSTICK

Retired Moderator
Messages
5,145
Likes
0
My Satellite Setup
Dreambox 7000, Skystar2
My Location
Brighton
#11
You should understand that I have a twin LNB, though mine isn't upside down...!

580cb483683c5e1975ec565a5d642df0.jpg
 
S

satdown

Member
Messages
3
Likes
0
#12
Sorry I've taken so long to reply, but my internet access was down, I managed to disconnect it with my foot.
Your LNB looks similar to mine, but mine is single, the connection is the same when I am doing a handstand on the roof.
My main problem seemed to be the disecq switch, now I have set the dreambox up as priority, I don't seem to be having the problems.
I'll post again if I get further problems, thanks for now.
By the way, I assume if you are positioning via a skystar, it is connected to the motor and then to the first LNB connection, whereas the dreambox is connected straight to the second LNB connection. Note: I don't have a disecq motor so I am just guessing here.
 
BGonaSTICK

BGonaSTICK

Retired Moderator
Messages
5,145
Likes
0
My Satellite Setup
Dreambox 7000, Skystar2
My Location
Brighton
#13
Yep, you got it. :)
 
Top