Trouble setting up network for 7020

astral69

astral69

Regular Member
Messages
145
My Satellite Setup
Dreambox 7020Si receiver, PLi image loaded and Irdeto and Viaccess cards installed. Dishes for Nilesat + Hotbird with lnb's for BADR and Eurobird 9
My Location
Middle East
I have run a LAN cable from my 7020 to my router, the light on the router indicates a good connection, no light on the 7020 end :mad:
I have set up the address on the 7020, 192.168.1.22, (the router is 192.168.1.254) but the router does not report seeing the 7020.
As an alternative I have tried DHCP but no luck there either.

Help........ What have I done wrong?

Yes, I have read the Idiots Guide

PS I did have this working some months ago, because I installed Flash Pro and the PLi image. I do not remember any special problems at that time.
 
H

HB13DISH

Retired Mod
Messages
3,764
My Location
Middle East - Israel
astral69 said:
I have run a LAN cable from my 7020 to my router, the light on the router indicates a good connection, no light on the 7020 end :mad:
I have set up the address on the 7020, 192.168.1.22, (the router is 192.168.1.254) but the router does not report seeing the 7020.
As an alternative I have tried DHCP but no luck there either.

Help........ What have I done wrong?

Yes, I have read the Idiots Guide

PS I did have this working some months ago, because I installed Flash Pro and the PLi image. I do not remember any special problems at that time.
You can try changing the IP's for both 7020 and router and see if this helps.
Did you install any any anti virus applications or internet security?
Sometimes they can block the network. Try to deactivate it for few minutes.
 
Jimdefruit

Jimdefruit

Member
Messages
6
My Satellite Setup
VU+ Duo, Dreambox 7000s plus all the bits and all intreconnected.
My Location
Hampshire
On the 7020, did you fill in the gateway and other entries and enable the network?

If you enabled the dhcp on the 7020, is the dhcp option enabled on the router?
 
astral69

astral69

Regular Member
Messages
145
My Satellite Setup
Dreambox 7020Si receiver, PLi image loaded and Irdeto and Viaccess cards installed. Dishes for Nilesat + Hotbird with lnb's for BADR and Eurobird 9
My Location
Middle East
HB13DISH said:
You can try changing the IP's for both 7020 and router and see if this helps.
Did you install any any anti virus applications or internet security?
Sometimes they can block the network. Try to deactivate it for few minutes.
I have tried different IP addresses, both static and DHCP on the 7020.
There are both static and dynamic address ranges on the router config.
I did put in the gateway address and made sure the Network box is checked. (Pli Image)
I am wary of changing the router address.

On the 7020 no antivirus installed or security.

I just took my notebook to the other room to check the cable.
The router immediately recognised the laptop on the different port.

Could it be that I have a duff LAN port on the 7020?
How can I test that?
 
dig deep

dig deep

Prince of Birthdays
Staff member
Messages
7,638
My Satellite Setup
Dream7020 and AZ Elite and a few DM800
My Location
Sweden
Start by finding the IP of the 7020.

Reboot and press the lower right hand button and You will see the IP

Reboot again and try to ping that adress. If that work then You have a good connection.

Make sure that the box is free, no tick in the dhcp in the setup
 
astral69

astral69

Regular Member
Messages
145
My Satellite Setup
Dreambox 7020Si receiver, PLi image loaded and Irdeto and Viaccess cards installed. Dishes for Nilesat + Hotbird with lnb's for BADR and Eurobird 9
My Location
Middle East
OK
I know the IP address, 192.168.1.20/255.255.255.0
not using dhcp.

Plugins/Tuxbox Commander/Execute command
ping 192.168.1.20 then press OK

Nothing happens.
The receiver is still giving me sound from the satellite, but the screen is locked
and a power off/on is needed for reboot.

Does this mean the LAN port is faulty?
 
dig deep

dig deep

Prince of Birthdays
Staff member
Messages
7,638
My Satellite Setup
Dream7020 and AZ Elite and a few DM800
My Location
Sweden
You must ping from a computer in the lan.

Get DCC and try to connect using that program.
 
astral69

astral69

Regular Member
Messages
145
My Satellite Setup
Dreambox 7020Si receiver, PLi image loaded and Irdeto and Viaccess cards installed. Dishes for Nilesat + Hotbird with lnb's for BADR and Eurobird 9
My Location
Middle East
OK

A ping fails.
The admin screen of the router does not show the DB on the network.........
 
dig deep

dig deep

Prince of Birthdays
Staff member
Messages
7,638
My Satellite Setup
Dream7020 and AZ Elite and a few DM800
My Location
Sweden
Are You dead sure You got the right IP for the box ??

DCC will help You to search for it. A foulty LAN port is a possibility but test all first to make sure.
 
L

LowNoiseBloke

Member
Messages
47
Location
S.Staffs., U.K.
My Satellite Setup
Force Frontier 90,2xEmp-Centauri P168(28.2,23.5,19.2,16,13,9,5E,5W)
Vu+Duo2 & Now TV, Amazon Fire TV & Droidbox X7,
Buffalo Linkstation,
Pace TDS850NB Sky+HD,
Ubuntu/Fedora servers,
Technisat AirStar/Freeview.
My Location
South Staffs. U.K.
Check firewall settings - router and PC.
Make sure cat5 cable is not a cross-over type - try connecting to PC directly from DM7020.
What does this mean : "no light on the 7020 end" ? - no red light on motherboard ?. If so then the cable or the 7020 could be faulty.
 
astral69

astral69

Regular Member
Messages
145
My Satellite Setup
Dreambox 7020Si receiver, PLi image loaded and Irdeto and Viaccess cards installed. Dishes for Nilesat + Hotbird with lnb's for BADR and Eurobird 9
My Location
Middle East
LowNoiseBloke said:
Check firewall settings - router and PC.
Make sure cat5 cable is not a cross-over type - try connecting to PC directly from DM7020.
What does this mean : "no light on the 7020 end" ? - no red light on motherboard ?. If so then the cable or the 7020 could be faulty.
Cable is straight as I can use it to connect my notebook, instead of the DB
so cable is OK
No red (LAN) light on the motherboard of Db, that I can see.
Should there be one??
I do not recollect one, even when it was working a few months back.

Running DCC searching but only finds router, not DB.

Can I plug in a wireless access point to the usb and use that instead?
 
L

LowNoiseBloke

Member
Messages
47
Location
S.Staffs., U.K.
My Satellite Setup
Force Frontier 90,2xEmp-Centauri P168(28.2,23.5,19.2,16,13,9,5E,5W)
Vu+Duo2 & Now TV, Amazon Fire TV & Droidbox X7,
Buffalo Linkstation,
Pace TDS850NB Sky+HD,
Ubuntu/Fedora servers,
Technisat AirStar/Freeview.
My Location
South Staffs. U.K.
@Astral69 - sorry for the wrong colour !. It's red on a 7000 but green on a 7020. Your router appears to recognise that something is connected so apart from configuration problems or faulty hardware (router,cable,dreambox) we are left with faulty firmware. Maybe you need to reflash the box ?.
 
astral69

astral69

Regular Member
Messages
145
My Satellite Setup
Dreambox 7020Si receiver, PLi image loaded and Irdeto and Viaccess cards installed. Dishes for Nilesat + Hotbird with lnb's for BADR and Eurobird 9
My Location
Middle East
I opened the DB up. No light at all for the LAN.

I can eliminate the router and cable, as I can connect my laptop on the end of the cable and it works perfectly.

So I guess it means a fault on the DB.
That appears to mean replacing the entire motherboard...... Ouch

I will look at doing a reflash.
Can I do that with just the RS232??
 
L

LowNoiseBloke

Member
Messages
47
Location
S.Staffs., U.K.
My Satellite Setup
Force Frontier 90,2xEmp-Centauri P168(28.2,23.5,19.2,16,13,9,5E,5W)
Vu+Duo2 & Now TV, Amazon Fire TV & Droidbox X7,
Buffalo Linkstation,
Pace TDS850NB Sky+HD,
Ubuntu/Fedora servers,
Technisat AirStar/Freeview.
My Location
South Staffs. U.K.
I think you can flash a 7020 with just a null modem cable - check the manual, but before you do try disconnecting the box from the mains for 3-4 hours and then try again. A couple of times this has got me out of trouble when I was considering a reflash. The lack of any light visible on the motherboard is a bad sign. Best of luck.
 
astral69

astral69

Regular Member
Messages
145
My Satellite Setup
Dreambox 7020Si receiver, PLi image loaded and Irdeto and Viaccess cards installed. Dishes for Nilesat + Hotbird with lnb's for BADR and Eurobird 9
My Location
Middle East
LowNoiseBloke said:
The lack of any light visible on the motherboard is a bad sign. Best of luck.
There is NO light on the motherboard to be visible..........................
 
L

LowNoiseBloke

Member
Messages
47
Location
S.Staffs., U.K.
My Satellite Setup
Force Frontier 90,2xEmp-Centauri P168(28.2,23.5,19.2,16,13,9,5E,5W)
Vu+Duo2 & Now TV, Amazon Fire TV & Droidbox X7,
Buffalo Linkstation,
Pace TDS850NB Sky+HD,
Ubuntu/Fedora servers,
Technisat AirStar/Freeview.
My Location
South Staffs. U.K.
There is NO light on the motherboard to be visible.........................
Your box must be a different release to my 7020. I can see lights just by peering through the vents on the cover - no need to take the lid off. Could yours be a clone, not an original DM box ?.
All I can advise now is to back off from the problem for a while and then go back and check all of the points mentioned by the various posters. After that I would say you need some local help, an understanding dealer maybe ?.
 
Top