Whyte irs multiswitch

A

Arinb12

New Member
Messages
9
Likes
1
My Satellite Setup
Communal sky
My Location
London
#1
We have a whyte WATS-530 launch amplifier fitted into our communal system. Today all things stopped working, no sky no freeview Ariel. I've checked the launch amplifier which is powered by an IRS 18v PSU, this PSU has power running all the way down the cable from the mains, so I know the PSU is working, but for some reason when plugging into the launch amplifier, the green led will not light up even with the switch on, can anyone help? Should it light up?

Even when testing the PSU when plugged into the launch amplifier the electrical tester will say there is no electricity running through it, where as before plugging it in, the tester said there was power running all the way through the PSU cable to the connector point

This is what we have Whyte Series 5 Launch Amplifier 4 X SAT 30dB / TERR 24dB inc E/Bar
 
Lazarus

Lazarus

Tout Rond Bon Oeuf
Staff member
Messages
25,211
Likes
7,556
My Satellite Setup
80cm Motorised.
Several small Dishes.
Much else.
My Location
North York Moors
#3
Installer Members were most likely in bed when you first Posted and will be at work now.

I guess you might need to wait a little longer :)
 
PaulR

PaulR

Dazed and Confused Admin
Staff member
Messages
15,990
Likes
3,171
My Satellite Setup
-----------See sig-----------
My Location
Wirral, NW UK and Vaucluse, France.
#4
Can you take the PSU next to the launch amp and with a temporary mains feed see if the launch amp works when fed with power directly?
 
A

Arinb12

New Member
Messages
9
Likes
1
My Satellite Setup
Communal sky
My Location
London
#5
Not sure I understand what you mean. There is a power socket in the cupboard, which the PSU is plugged into. The PSU is then plugged into the launch amplifier using its coaxial type of connector it is fitted with. I used an electrical tester to see if the psu was not recieving any power all the way through to the connector plug, i.e. was the PSU at fault. It looks like it's recieving power all the way to the tip down the wire, but once I plug it into the launch amplifier when I retest the wiring, the electrical tester shows no current flowing through and the launch amplifier hasn't got a green on light ( I have tried two PSU's, both do the same thing)
 
jeallen01

jeallen01

Specialist Contributor
Messages
3,377
Likes
1,397
My Satellite Setup
See Signature
My Location
Somewhere in England (possibly?)!
#6
Sounds to me like either:
- the launch amp has an internal dead short across the power input terminals (or another internal fault which causes it to draw excessive current) , and that causes the PSU o/p to "fold back" and close down when it is connected to the amp, or else the actual input socket itself might be damaged.
or
- the PSU itself is faulty: your test of the PSU may have confirmed that it is outputting voltage but there may be an internal fault and it can't now delivery any/enough current for the amp.
 
rolfw

rolfw

Believe it when I see it Admin.
Staff member
Messages
37,770
Likes
1,309
My Satellite Setup
Technomate 5402 HD M2 Ci, DM7000s, Transparent 80cm Dish, Moteck SG2100 DiseqC motor, lots of legacy gear. Meters: Satlook Digital NIT, Promax HD Ranger+ spectrum analyser.
My Location
Berkshire
#7
Photos would help, what else is the PSU powering?

In a normal setup it would be powering a multiswitch downline, possibly even two or three.

PS. If this is a serviced or newish system, you fiddling with it may void any guarantee by the installer/service contract holder.
 
PaulR

PaulR

Dazed and Confused Admin
Staff member
Messages
15,990
Likes
3,171
My Satellite Setup
-----------See sig-----------
My Location
Wirral, NW UK and Vaucluse, France.
#8
Not sure I understand what you mean. There is a power socket in the cupboard, which the PSU is plugged into. The PSU is then plugged into the launch amplifier using its coaxial type of connector it is fitted with. ...
Sorry, I read your first post that the PSU was in a different place to the launch amp and sent the power to it remotely. Ignore what I said.
 
Lazarus

Lazarus

Tout Rond Bon Oeuf
Staff member
Messages
25,211
Likes
7,556
My Satellite Setup
80cm Motorised.
Several small Dishes.
Much else.
My Location
North York Moors
Top