Yet another boot problem

S

Simba3

Member
Messages
1
My Satellite Setup
DreamBox 5600
My Location
Netherlands
Unaible to get it to work again using all the different forums I decided to post this one.

Using Dreamup, I can send new images without any problem,
CRC-checks are ok and flashing works.
When I boot the box, it stops at "----" in the display with no image on the screen. Using Hyperterminal it stops at "now booting kernel"

In the Dreambox 7000 forum I found the post below and tried everything explained in there.

http://www.satellites.co.uk/satellite/dreambox7000/144627-dm7000s-now-booting-kernel.html[/URL]

Using Hyperterminal, this is what happened:

Linux/PPC load: console=null root=/dev/mtdblock5 rootfstype=squashfs ro
Uncompressing Linux...done.
Now booting the kernel

Nothing happened! Reboot:

Dreambox DM5620
loaded at: 00500000 0060816C
relocated to: 00400000 0050816C
board data at: 00506124 0050616C
relocated to: 00405194 004051DC
zimage at: 004058D1 005054F8
avail ram: 00509000 02000000

Changed :
Linux/PPC load: console=null root=/dev/mtdblock5 rootfstype=squashfs ro

Into
Linux/PPC load: console=ttyS0,115200 root=/dev/mtdblock5 rootfstype=squashfs rw
Uncompressing Linux...done.
Now booting the kernel
Linux version 2.6.9 (tux@tux) (gcc version 3.4.4) #1 Fri Dec 19 23:20:31 CET 200
8
Built 1 zonelists
Kernel command line: console=ttyS0,115200 root=/dev/mtdblock5 rootfstype=squashf
s rw
PID hash table entries: 256 (order: 8, 4096 bytes)
Console: colour dummy device 80x25
Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)
Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)
Memory: 29992k available (1740k kernel code, 592k data, 80k init, 0k highmem)
Mount-cache hash table entries: 512 (order: 0, 4096 bytes)
NET: Registered protocol family 16
Squashfs 2.2-r2 (released 2005/09/08) (C) 2002-2005 Phillip Lougher
devfs: 2004-01-31 Richard Gooch (rgooch@atnf.csiro.au)
devfs: boot_options: 0x1
JFFS2 version 2.2. (NAND) (C) 2001-2003 Red Hat, Inc.
Serial: 8250/16550 driver $Revision: 1.90 $ 7 ports, IRQ sharing disabled
ttyS0 at MMIO 0x0 (irq = 20) is a 16550A
ttyS1 at MMIO 0x0 (irq = 21) is a 16550A
ttyS2 at MMIO 0x0 (irq = 22) is a 16550A
loop: loaded (max 8 devices)
ne.c:v1.10 9/23/94 Donald Becker (becker@scyld.com)
Last modified Nov 1, 2000 by Paul Gortmaker
NE*000 ethercard probe at 0xc3060600:<4>eth0: interrupt from stopped card
00 09 34 1e c2 52
eth0: NE2000 found at 0xc3060600, using IRQ 25.
Universal TUN/TAP device driver 1.5 (C)1999-2002 Maxim Krasnyansky
Using deadline io scheduler
dreambox: flash mapping: 800000 at 7f800000
DreamBOX rev3+: Found 1 x16 devices at 0x0 in 16-bit bank
Intel/Sharp Extended Query Table at 0x0031
Using buffer write method
cfi_cmdset_0001: Erase suspend on write enabled
disable flash VPP
Creating 7 MTD partitions on "DreamBOX rev3+":
0x00000000-0x00500000 : "DreamBOX cramfs+squashfs"
0x00500000-0x007c0000 : "DreamBOX jffs2"
0x007c0000-0x00800000 : "DreamBOX OpenBIOS"
0x00000000-0x007c0000 : "DreamBOX (w/o bootloader)"
0x00000000-0x00800000 : "DreamBOX (w/ bootloader)"
0x00120000-0x00500000 : "DreamBOX SquashedFS"
0x00000000-0x00120000 : "DreamBOX Cramfs"
mice: PS/2 mouse device common for all mice
i2c /dev entries driver
IBM IIC driver v2.1
ibm-iic0: using standard (100 kHz) mode
NET: Registered protocol family 2
IP: routing cache hash table of 512 buckets, 4Kbytes
TCP: Hash tables configured (established 2048 bind 4096)
NET: Registered protocol family 1
NET: Registered protocol family 17
VFS: Mounted root (squashfs filesystem) readonly.
Mounted devfs on /dev
Freeing unused kernel memory: 80k init
init started: BusyBox v1.01 (2008.12.19-22:20+0000) multi-call binary
head: module license 'Proprietary' taints kernel.
fp: attaching fp at 0xee to adapter IBM IIC
framebuffer mem base: a0900000
0/0: 00003000 80f00000
0/1: 01003000 80f00000
1/0: 20003000 80f00000
1/1: 21003000 80f00000
trying to memset ..
ok.
fb_find_mode returned 0
allocated major 250 for denc.
[DENC] set PAL
[DENC] disable WSS
core: Loaded IBM STB02xx core driver
audio init
AUDIO_CLEAR_BUFFER
demux: init
xp0_clk_stop
i2c_master_send failed.
stb04_pig: $Id: stb04_pig.c,v 1.16 2007/06/12 19:28:18 ghost Exp $
avs: attaching avs at 0x94 to adapter IBM IIC
[AVS] set 4:3
rfmod: INITed
write 1 event's ...


Now it stops here, still "----" is display and no image on screen.

Any help is welcome,
Simba3
 
T

totalacedude

Regular Member
Messages
118
My Satellite Setup
Edit. 5620 several 500,'s (clones) vu duo blackhole pc server 95cms motorised dish blah blahh
My Location
crewe
cap bash the psu and if you can the main board!
when the caps start to go it causes ripple on the power rails!
this in turn corrupts bits of the flash! maybe not a big bit, but enough to cause it to fail!

i had same fault!

bought it cheap cos it was faulty!

replaced all capacitors in it and bobs ur uncle!!!

ian
 
Top