Manhattan 5900

Messages
17
Likes
0
#1
Hi everyone
Nice to be on your forum :)
I have a problem and i was hoping that someone with more experience can help me.
I have manhattan 5900 -with built UCAS,the problem is that support for this reeciver is terrible,and the official forum has 1 post in 3 months ,and its in dutch unfortenately.
The Problem is that i can`t move channells with the official editor for this receiver(stb-editor v2 from eaglesoft),and the editor works with .img files.So i was hoping that some of u may help me,to tell me is there some other editor that i can use ,or some converter for .img to lets say .bin files.

Thanx in advance
 
Messages
27
Likes
1
#2
I Also have a 5900 which probably wouldn't work at all if not for the excellent help I recieved on this forum (Manhattans own forum is a complete waste of space, as you already know).

STB Editor is the only editor I know of for this range of recievers. Unfortunately it's lacking in one or two areas, most irritating of which is the moving and sorting of channels. I've found the best technique is to use STB Editor to edit names and keep up with new channels (using SatcoDX). Then download to the reciever to move the channels around.

A huge irritation for me is the inability to sort satellite order on the reciever. Reciever starts clean listed East to West. If you then use STB Editor, it puts 'em back in any old order. Does anyone know a way round this?
 

Channel Hopper

Suffering fools, so you don't have to.
Staff member
Messages
25,213
Likes
5,623
My Satellite Setup
A little less analogue, and a lot more crap.
My Location
UK South
#3
steve-j said:
I Also have a 5900 which probably wouldn't work at all if not for the excellent help I recieved on this forum (Manhattans own forum is a complete waste of space, as you already know).

Tunte - Why do you believe the Eagle soft editor is 'official' ?

The 5900 is a legend in that it was the worst of all the Manhattan brand, completely flawed from the day it was designed.

Unfortunately even later branded products suffer the similar 'amomalies' within the menu structure, the problem goes back to the 5500 series that would AWOL when you set a favourite list, the channel selection would go haywire
 
Messages
27
Likes
1
#4
Have to agree with Channel Hopper I'm afraid, definitely the pup in a flawed range.

I think 'anomalies' is actually being rather kind, the menus *look* nice but the flaws are fundamental (some of it should never have passed alpha testing)! I wouldn't even dream of describing it as an "enthusiasts" reciever - you won't be doing a deal of tweaking settings, applying patches, etc. with one of these.

I've read about the favourites (with a 6900 in that case), but never had a problem myself (I only keep a couple of lists - with pointers to the main packages rather than individual channels).

I actually enjoy the struggle with it (takes all sorts), and the results can be rewarding enough. Even the biggest Manhattan-phobe would be hard pressed to knock the picture and sound quality - after all, you don't "watch" the menus.

Steve
 
Messages
17
Likes
0
#5
First,thanx for the replays,I post this questions on 4 or 5 boards,and this is the only place i got response
@channel hoper,well i guess i think its official cause its the only one u can download from Mannhattan site(altough it doesnt have help??)
@steve-j i read ur posts regarding motor problem i think(it was on another board)and i asked u question there,i cant import satcodx becouse it says(missing closing parenthesis)and the editor locks up(with the channels unchecked),and i agree the picture and sound quality are great
Thanx for the replays
 
Messages
27
Likes
1
#6
I remember the thread about a motor problem (on Tonydoes as I recall). I tend to loose track of the threads I'm involved in if it goes over three or four, and I'm in about twice that at the moment :) .

Will check it out though and see if I can help.

Steve
 
Messages
17
Likes
0
#7
@steve-j
I uninstalled the editor,deleted the folder and installed it in another one,
but the problem is still here.When i try to import file(File-Import-Satcodx-file),the other
window shows up.I sort the sattelites and i drag the transponders in the main window of the
editor. I uncheck channels and another window shows up named DATA WINDOw saying"missing
closing parenthesis",with OK button on it.
After this the only way to close the windows is trough Task Manager.
I tryed with inly one transponder or with a group of selected transponders,and the weirdest
thing is that sometimes this happens and sometimes it doesntt,but i just cant`t getthe work done.
I am using XP and i tryed what u suggested (running in win 98 mode)but that didn`t helped too.
The .sdx file is from "satcodx world of satelites II",
but the same thing happens on every import,becouse i tryed to import stb file (.img),
and it freezes again.
any ideas?

p.s the editor is downloaded from manhattan`s site
 
Messages
27
Likes
1
#8
Have you tried downloading the software again? This might help if the first one was corrupt (quite possible as you are having trouble with more than one input format).

I'm a little unclear on where you're getting your *.sdx files. Let STB Editor get them over the internet on its own rather than taking them from another piece of software. A full download creates a single data file from around 130 files in 9 sub-groups, different software may well process them in different ways.

One other thought - Are you running an active screensaver (Seti@home, UD Agent or something similar)? These play absolute havoc with STB Editor and should be shut down before you use it.
 
Messages
17
Likes
0
#9
Thanx for the fast reply Steve-j
I dont run screensaver or virus checker or anything like that.
I am downloading the editor again right now but its almoust 10 megs so its gonna take a while
i`ll try to download sdx from web now like yosaid so and I`ll put a post tommorow and tell you how it went

thanx for trying to help me out with this one m8
I really apretiate it
 
Messages
17
Likes
0
#10
I downloaded the program again,and i downloaded sdx from stb editor,but it still makes the same problem.iI also deinstalled again,deleted all entries with registry cleaner and i installed on another hard drive(d insted c)but the same message appears"missing closing parenthesis"
 
Messages
27
Likes
1
#11
Have spent an hour or so trying to duplicate the problem, best(worst?) I could do was crash the program by trying to deliberately import the wrong file format (*.chd) from "World of Satellites II"
Try downloading the SatcoDX data with STB Editor and saving it as a file (*.sdx - around 2MB in size), then import from that file. Then try importing directly from the internet and see if there's any difference
 
Messages
17
Likes
0
#12
steve-j,i also have "World of Satellites II" and I have saved as a .sdx files but it is the same.Now either is some software conflict,or the stbeditor i downoaded is faulty(i got it from www.manhattan-receivers.com same place i got the first one from),or it has something to do with the files (when i run check in stb editor it says i have lets say 75 wrong channel data)
The thing is teh same freeze is when i import lyngsat.dat or .stb date so it couldnt be the .sdx file itself.
Now this may sound like a stupid question to you but the receiver isnt conected to my pc while i try to do this editing-could it be it?
I also start to think that it could be some lets say .dll file that the editor needs:(
i start to sound stupid m8
thanx for your help steve-j
 
Messages
27
Likes
1
#13
Not stupid m8, somethings wrong or we're missing something here! Let's deal with the easy ones first.

Wrong channel data is irrelevent, this is things like a video PID without a corresponding audio PID. A lot of feeds throw these up as well. Also, reciever only needs to be connected when uploading or downloading so not that either.

OK onto the tougher stuff;

I think it's unlikely to be a missing dll, or other file, I haven't had to load anything other than the program (although I keep all the VB runtimes in my system folder), nor is there any documented requirement to do so.

This brings us to the software and data files. I think the data files can be safely ruled out because you're getting the same error with three different files/formats which is VERY unlikely.

So, onto the software itself. Mine came from Manhattans' site and runs OK, but you could always get a copy from fortecstar.com if you want to rule the source out as an option.

As far as I can see, this leaves some sort of conflict or an input error. As I've already said, the program doesn't respond well to background tasks (Seti@home in my case), so bring up task manager and see if anything other than "System Idle Process" is eating your CPU time. If there is; disable it in some way and try again.

If all this fails, can you post a 123 of your sequence of actions from starting STB Editor through to it failing (include everything and assume you're writing it for an idiot (that's me)). The solution may be as obvious as a repeated input error that just needs a second set of eyes to find it!

Steve
 
Messages
17
Likes
0
#14
Steve-j
I am only sorry that You are far from me so i can`t buy you a beer:)
I will try that,and I will try that (experiment with the backgrounfd processes i have)so i will let you kno later
I will write that 1,2,3 step after i check this out

thanx for helping me
 
Messages
17
Likes
0
#15
mE again:)
I disabled all start-up precesses except ati-control panel,nothing uses
the processor except :"system idle process"

1.i start up stb editor
2.i make new image(file-read from stb),a report window shows showing osd setup,number of channells,favorite lists...
3.i save that data as a file (lets say 21.01.img)-(now i have a diseqc 1.2 motor and mostly i save it MODEL-CI,i have tryed with DC checked ,but its the same
4.file-import-satcodx-file-and the name of the file,I also tryed direct import from internet as u instructed steve-j,but the result is the same
5.new window shows up much like the main window except u have less options on right click(no delete,no edit..)
6.I sort the satelites of the main window by positon,and i sort the satelite of the import window the same
7.i select all the satellites i need (with shift)and i drag them to the satellites in the main window-the mouse has satellite form:)
8.an import window shows up with options --satellites(which is greyed and checked),--transponder (also checked),and channels (i uncheck that).I press ok
9.the window header changes to import satelites and it shows SELECTED;SATELLITE;TRANSPONDER;
TV CHANNEL,RADIO CHANNEL and also IMPORT;NEW;EXIST with green and red numbers.The numbers start changing and it goes to selected satellites 20 ,satellite-10,transponder 92,tv channel
43,radio channel 2 and a pop-up window with header DATA WINDOW show up with a yellow !mark saying "missing closing parenthesis"and ok button on it.I press ok,the numbers roll to satellites 20 ,satellite-15,transponder 129,tv channel 43,radio channel 2,and again the data window appears,this happens untill it rolls the number to the end.new window appears asking"do u wanna apply for import?"with yes and no buttons.Now this varys,if u select yes it freezes,or says application halt!,or it says just a momemt please and it freezes (i have left it lake that for more than 2o minutes and it stays the same)so i have to use task manager to end the process.

The weird part is that if i open one backup image ,and i try to import it the same one as stb file ---file-import-stb file,the new window appears.So the two windows are with same data,but the import satellite window(menteniod in number 8)shows that there are new transponders.Whatever import file i use(sdx,img,dat)the same things happens.

Every now an then when i try to close the application windows error report shows up,asking me if i want to send the data to miscroft.this is what it says:
------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------
<?xml version="1.0" encoding="UTF-16"?>
<DATABASE>
<EXE NAME="stbeditor.exe" FILTER="GRABMI_FILTER_PRIVACY">
<MATCHING_FILE NAME="stbeditor.exe" SIZE="3678720" CHECKSUM="0xB5F78650" BIN_FILE_VERSION="8.0.3.9704" BIN_PRODUCT_VERSION="8.0.3.9704" PRODUCT_VERSION="1.06c" FILE_DESCRIPTION="Sybase Inc. Product File" COMPANY_NAME="EagleSoftware Co.,Ltd." PRODUCT_NAME="STB Editor" FILE_VERSION="8.0.3.9704" INTERNAL_NAME="PB 8" LEGAL_COPYRIGHT="Contains licensed copyright material by Sybase Inc. and others. Use and distribution of Sybase copyright material and licensed material is governed by Sybase End-user License Agreement." VERFILEDATEHI="0x0" VERFILEDATELO="0x3E64F4A4" VERFILEOS="0x10001" VERFILETYPE="0x1" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" UPTO_BIN_FILE_VERSION="8.0.3.9704" UPTO_BIN_PRODUCT_VERSION="8.0.3.9704" LINK_DATE="03/04/2003 18:47:00" UPTO_LINK_DATE="03/04/2003 18:47:00" VER_LANGUAGE="English (United States) [0x409]" />
</EXE>
<EXE NAME="kernel32.dll" FILTER="GRABMI_FILTER_THISFILEONLY">
<MATCHING_FILE NAME="kernel32.dll" SIZE="930304" CHECKSUM="0xCBCCF8A9" BIN_FILE_VERSION="5.1.2600.1106" BIN_PRODUCT_VERSION="5.1.2600.1106" PRODUCT_VERSION="5.1.2600.1106" FILE_DESCRIPTION="Windows NT BASE API Client DLL" COMPANY_NAME="Microsoft Corporation" PRODUCT_NAME="Microsoft® Windows® Operating System" FILE_VERSION="5.1.2600.1106 (xpsp1.020828-1920)" ORIGINAL_FILENAME="kernel32" INTERNAL_NAME="kernel32" LEGAL_COPYRIGHT="© Microsoft Corporation. All rights reserved." VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x40004" VERFILETYPE="0x2" MODULE_TYPE="WIN32" PE_CHECKSUM="0xE7ED3" LINKER_VERSION="0x50001" UPTO_BIN_FILE_VERSION="5.1.2600.1106" UPTO_BIN_PRODUCT_VERSION="5.1.2600.1106" LINK_DATE="08/29/2002 10:40:40" UPTO_LINK_DATE="08/29/2002 10:40:40" VER_LANGUAGE="English (United States) [0x409]" />
</EXE>
</DATABASE>
--------------------------------------------------------------------------
--------------------------------------------------------------------------

as far i can understand this,stb editor makes conflict with Windows NT BASE API Client DLL??

Steve-j i dont know how much will you understand this, now when i read it second time it doesnt quite look the way i intended(1,2,3 step:)

So i have another idea,can i send you my img file.like attachment to your mail,and you to try to import transponders?maybe the files i get from my manhattan have something missing?

Am i bugging you with this?
are we gonna apply for (THE LONGEST FORUM THREAD ANNUAL AWARD?)
:):):)
 

Razor

Regular Member
Messages
1,319
Likes
0
My Location
Ireland
#16
You will never get the longest thread award.

That is reserved for people with Force D-Masters 1122s...It takes 2 pages of posts just to turn them on...Never mind editing the channels.
 

Channel Hopper

Suffering fools, so you don't have to.
Staff member
Messages
25,213
Likes
5,623
My Satellite Setup
A little less analogue, and a lot more crap.
My Location
UK South
#18
Nah - keep it as a spare
 
Messages
27
Likes
1
#19
Not bugging me m8

Let me work through it Thursday, and I'll post late evening or Friday.

Steve

ps These D Masters sound like fun :D I'll have to get one if the Manhattan ever dies again ;) .
 
Top